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Preface 

 

This course introduces the students to basic computer systems’ terminology, structure, and data 

representation, as well as the usage of different popular computer applications. It also familiarizes 

students with algorithms and the process of writing pseudo code. The course also serves as an 

introductory course in programming by using C as a tool to design simple programs. In addition, the 

course touches on Computer Science as a discipline by presenting an overview of different Computer 

Science topics as well as the ethics of computing. Upon completion of this course, the students will 

have a basic understanding of simple Computer Science and computer programming concepts. 

The students will also be able to: 

 Use different popular computer applications such as MS Office. 

 Write algorithms (pseudo Code) to solve simple tasks. 

 Use C to build simple programs. 
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Experiment 1: Operating System (Windows 10). 

  

1.1 Objectives 

 To understand the role of operating system in computers  

 To be familiar with different version of operating systems working on different devices  

 To be familiar with main features in Windows 10  

 To perform simple operations and action on Windows  

 To gain the ability to differentiate between different computer specifications  

 

1.2 Context 

  

An operating system (commonly abbreviated OS and O/S) is an interface between hardware and 

applications; it is responsible for the management and coordination of activities and the sharing of the 

limited resources of the computer. The operating system acts as a host for applications that run on the 

machine. As a host, one of the purposes of an operating system is to handle the details of the operation 

of the hardware. The OS is like the behind-the scenes-manager who takes care of all computing tasks 

such as saving your work, printing a document, starting a program, and so on.   

 

Figure 1. 1 OPERATING SYSTEM 

 

  

Common contemporary operating systems include Microsoft Windows, Mac OS, and Linux. Microsoft 

Windows has a significant majority of market share in the desktop and notebook computer markets, 

while servers generally run on Linux or other Unix-like systems.   

The operating system (OS) is a program that allows you to interact with all of the software and 

hardware on your computer, mainly there is two interaction types with operating systems:   

Command-line Interface (CLI): (e.g., DOS), you type a text command and the computer responds 

according to that command.   
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Graphical User Interface (GUI): (e.g., Windows), you interact with the computer   through a graphical 

interface with pictures and buttons by using the mouse and keyboard. With UNIX, you have in general 

the option of using either command-lines (more control and flexibility) or GUIs (easier).  

A graphical User Interface (GUI) is a type of user interface, which allows people to interact with 

electronic devices. A GUI offers graphical icons, and visual indicators, as opposed to text-based 

interfaces, typed command labels or text navigation to fully represent the information and actions 

available to a user. The actions are usually performed through direct manipulation of the graphical 

elements.  

  

 Windows 10 main components and features   

  Desktop  

After your computer starts up, it prompts you to enter username and password. Logging on to computer 

identifies your personal settings and grant special permission for users. Afterward, Desktop appears 

automatically, which is considered your work area that contains files, icons, shortcuts and other menus.  

The taskbar is located on the bottom edge of your desktop. You can move taskbar to other locations. It 

enables you to switch between open programs and documents, and you can launch some programs 

pinned to taskbar.  

 

Figure 1.2: WINDOWS 10 TASKBAR 

  

 Parts and contents:  

Start menu: the central menu to access folders, programs and commands on your computer. 

 

Figure 1.3: START MENU IN WINDOWS 10 

Using the menu item “All apps”, you can access your computer programs.  
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To start a program:   

Click the Start button, located in the lower left corner of your screen.   

Highlight Programs. The Program menu will appear.   

Move to the Program menu and highlight the program you want to start. If you see a right pointer next 

to your selection, a submenu will appear. Refine your choice by highlighting the appropriate selection 

on the submenu. Continue until you get to the final submenu.  

Click the program name to start the program.   

Menu: is a list of related commands, when you click a menu item, a drop-down menu appears. Select 

the command you want to execute from the drop-down menu. Sub menus, are associated with specific 

program groups. The small arrow to the far right recognizes them.  

Icon: is a small image that represents an item ready to be open (e.g.  File, folder) or launched (e.g. a 

program).  

Desktop shortcut: is a small file that points to a program, folder, document, or Internet location and 

usually represented by an icon. When clicking on shortcut icon it takes you directly to the object, it 

points into it. Shortcut icons contain a small arrow in their lower left corner. Shortcuts are considered 

as a merely pointer, deleting shortcut will not delete the original item.  

 

 Shutdown options:  

 

Figure 1. 4 SHUTDOWN OPTIONS IN WINDOWS 10 

 

  

Shut Down: If you click the Shutdown button, Windows 10 ties up all the loose ends and shuts down 

the computer completely. You would normally do this to turn off your work computer at the end of the 

day.  

 

Restart: The Restart button "reboots" your computer, that means it saves your information to the hard 

drive, turns off the computer for a moment, and then turns it back on again. This is most often done 

after fixing a problem, adding a new program, or making a configuration change to Windows that 

requires a restart.   

 

Sleep: Clicking on Sleep puts your computer in a low-power state, but does not turn it off. The main 

advantage is that it allows you to get back to work quickly, without having to wait for the computer to 

do a full reboot, which can take several minutes.  

 

Hibernate: Hibernate mode is intended mainly for laptop users. It is sort of a compromise between 

Shut down and Sleep modes. It remembers the current state of your desktop and fully shuts down the Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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computer. Therefore, if, for instance, you have a web browser open, a Microsoft Word document and 

a chat window, it would turn off the computer, while remembering what you were working on. Then, 

when you start up again, those applications will be waiting for you, right where you left off.  

 

 Rectangular windows  

Windows: is a rectangular portion of your screen where a program runs. You can open several 

windows at the same time. Windows can be moved, resized, closed, maximized or minimized.  

Windows are usually depicted as two-dimensional objects (like papers or books) arranged on a desktop. 

Most windows can be resized, moved, hidden, restored, and closed. When two overlap, one is on top 

of the other, with the covered part of the lower window not visible. However, many programs with 

text user interfaces, allow their display to be divided into areas that may also be referred to as 

"windows”. Include creating a new file, arranging the icons or changing how the desktop appears 

(Properties or Personalize).  

  

  

A window contains:     

 Title bar: the title bar displays the name of the current file and the name of the current program.  

 Toolbar: is a block of buttons or icons, when you click one of these buttons or icons, the 

program carries out a command or task.  

 Minimize button: use the minimize button to temporarily decrease the size of a window or 

remove a window from view. While the window is minimized, the title appears on the taskbar.  

 Maximize button: click the maximize button to make the window fill the screen.  

 Restore button: after maximizing a window, if you click the restore button, the window will 

return to its original size.  

 Close button: clicking on close button to exit the window and close the program.  

 Search Bar: using the search bar you can search for any file in the current directory.  

 Local Disk (Hard Drive): hard drive is the pace where all system and user files are stored, all 

programs installed also on the hard drive.  

 CD Drive: when you need to access files or program stored on external CD.  

 

Figure 1. 5 WINDOW PARTS 

Switch between windows  
 

If you have several windows open at the same time, the window on the top is the window with focus. 

You can only interact with the window with focus. To change windows, do one of the following:   

1. Click anywhere on the window you want to focus on.   

2. Hold down the Alt key and press the Tab key (Alt +Tab) until you select the window to which 

you want to view.   
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3. All active files displayed on the taskbar. Click the taskbar button for the window you want to 

focus on.  

 

 Windows Explorer  

What is Windows Explorer?  

Windows Explorer is your tool to work with files, folders, programs, hyperlinks, Control panel and 

much more. The starting point for work with Windows Explorer is often My PC. That system folder 

shows and gives access to most of the computer resources.  

My Computer includes files and programs, folders and hyperlinks, drives and printers as objects. From 

the operating system viewpoint, they are all objects, and each object is associated with an icon. The 

system folder My Computer gives access to almost all of the computers data programs. Each object is 

represented with an icon plus some text.  

 

Figure 1. 6 WINDOWS EXPLORER 

  

Drives: Whole hard disks or parts of them (partitions), plus CD-ROMs etc. A drive typically contains many folders.  

Folders: Containers for files that you can create yourself. A folder often contains many files.  

Files: The smallest data units that we have access to. A file can be a whole document or a part of one.  
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 Type Icon Description 

 

HTML 

 

HTML-documents.  Contain typically home pages. Can be 

viewed in a browser like google Chrome. 

DOC, DOCX 

 
  

Microsoft  office  word document, to edit and modify 

documents.  

XLSX, XLS 

 
  

Microsoft Excel spread sheets. Excel sheets used to save data and 

make some calculations.  

BMP 

PNG 

GIF 

JPG  
  

Images with different extensions can be viewed on windows, 

these images can be used in other program like Microsoft office,  

Photoshop, etc…  

AVI 

MP3 

MP4  
  

Movies (video recordings).   

Can be created with programs like Movie Maker and be played 

with Windows Media Player.  

 

Microsoft Edge: Web browser introduced in Windows 10 used to access web pages on internet.  

Recycle Bin: When you delete an object, Windows 10 sends it to the Recycle Bin. You can restore 

objects that are located in the Recycle Bin or you can permanently delete them.  

Control Panel: is the entry to PC for various settings such as controlling hardware units, user’s 

accounts, installed programs, languages, and others.  

 

Windows Explorer views  

 

Views control how Windows Explorer displays information in the right pane. Windows Explorer 

provides you with the following choices: Thumbnails, Tiles, Icons, List, and Details.  

 

 Thumbnails view displays images. These images represent the contents of folders and files.   

 Tiles view and Icons view display icons to represent drives, folders, and the contents of folders. 

The icons displayed when you choose Tiles view are larger than the icons that display when 

you choose Icon view.   

 List view displays all of the files and folders without supplying the size, type, or date modified.   

 Details view displays the size, type, and date modified.   

 

To change the view: 

   

1. Right-click any free area in the right pane. A context menu will appear.   
Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

7 

2. Highlight View.   

3. Select the view you want from the drop-down menu.   

 

Commands you can do using Windows Explorer  

 

To create a new folder in Windows Explorer:   

 

1. In the left pane, click the drive or folder in which you want to create the new folder.   

2. Click any free area in the right pane. A context menu will appear.   

3. Highlight New.   

4. Click Folder.   

5. Type a name for the folder.   

 

To create a shortcut to an item located on the Start menu:   

 

1. Click Start. The Start menu will appear.   

2. Locate the item to which you want to create a shortcut. If the item is located on a submenu, go 

to the submenu.   

3. Click and drag the item to your desktop.   

 

To create a shortcut to items visible in Windows Explorer:   

1. Open Windows Explorer.   

2. Minimize the Windows Explorer window.   

3. Locate in Windows Explorer the item to which you want to create a shortcut.   

4. Hold down the right mouse button and drag the item onto the desktop.   

5. Release the right mouse button. A context menu will appear.   

6. Click Create Shortcuts Here.   

 

Rename a desktop shortcut / file or folder:   

1. Right-click the shortcut / the file or folder. A context menu will appear.   

2. Click Rename.   

3. Type the new name.   

 

 

To delete a file or folder:   

1. Right-click the file or folder you want to delete. A context menu will appear.   

2. Click Delete. Windows Explorer will ask, "Are sure you want to send this object to the recycle 

bin?"   

3. Click Yes.   

 

Cut, copy, and paste  

 
The Cut, Copy, and Paste commands are nearly universal. These three functions are used by almost every 

Windows program and perform more or less the same function in each of them. You can cut, copy, and paste 

programs, disks, and text.   

 

Cut: When you cut something, it is deleted from its current location and saved to the Clipboard then 

you can paste it into other place (you move file or folder from one place to another).  

Copy: Copy is similar to Cut except the original item is not deleted from its original place. When you 

copy something, a copy of the item is saved to the Clipboard then you can paste it into other place (you 

duplicate a file or folder).  

Paste: You can place information on the Clipboard wherever you like. Execute the Paste command 

takes information you have cut or copied and placed it wherever your cursor is located.   
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Clipboard: The Clipboard is the storage area for items that have been cut or copied. Information saved 

to the Clipboard stays there until new information is either cut or copied. Each time you execute Cut 

or Copy, you replace the old information on the Clipboard with whatever you just cut or copied. You 

can paste Clipboard information as often as you like, until you replace it with something else.   

 

There are three major methods of cutting, copying, and pasting. The three methods are using the menu, 

using keyboard shortcuts, and using icons. We will review all of them. In most programs, they will 

work exactly as described here: 

 

1. Using the Menu   

 Cut   

1. Select what you want to cut.   

2. Click Edit menu, which is located on the menu bar. A drop-down menu will appear.   

3. Click Cut.   

 Paste   

1. Place the cursor at the point where you want to place the information that is currently on 

the Clipboard.   

2. Click Edit. A drop-down menu will appear.   

3. Click Paste.   

 Copy   

1. Select what you want to copy.   

2. Click Edit, which is located on the menu bar. A drop-down menu will appear.   

3. Click Copy.   

 

To copy a file or folder:   

1. Right-click the file or folder you want to copy. A context menu will appear.   

2. Click Copy. The file or folder should now be on the Clipboard.   

To cut a file or folder:   

1. Right-click the file or folder you want to cut. A context menu will appear.   

2. Click Cut. The file or folder should now be on the Clipboard.   

 

Note: Cutting differs from deleting. When you cut a file, the files are placed on the Clipboard 

and wait to be paste. When you delete a file, the file is sent to the Recycle Bin and cannot be 

paste into other place.  

 

       To paste a file or folder:   

1. After cutting or copying the file, right-click the object or right-click in the right pane of the 

folder to which you want to paste. A context menu will appear.   

2. Click Paste.  

 

2. Using keyboard shortcuts:  

 Copy   

1. Select what you want to copy.   

2. Press the keyboard buttons “Ctrl” and “c”.  

 Cut   

1. Select what you want to cut.  

2. Press the keyboard buttons “Ctrl” and “x”.  

 Paste   

1. Place the cursor at the point where you want to place the 

information that is currently on the Clipboard.   

2. Press the keyboard buttons “Ctrl” and “v”.  

3. Using Icons from toolbar:   

 If you want to copy or cut something, select it then press the suitable icon.  Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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 If you want to paste something already being cut or copied, place the cursor at the point where 

you want to place the information that is currently on the Clipboard and press the paste icon.   

 

 

Windows 10 main features  

Build in applications  

Windows 10 comes with elegant built-in applications like Maps, Photos, Mail & Calendar, Groove, 

and Movies & TV. These apps use OneDrive to back up your information and synchronize across your 

Windows 10 devices.  

 

Store  

The Store is a one-stop shop for music, videos, games, and apps.  

 

Figure 1. 7 WINDOWS 10 STORE 

  

  

Cortana  

What is Cortana?  

Cortana is your clever new personal assistant.  

Cortana will help you find things on your PC, manage your calendar, track packages, find files, chat 

with you, and tell jokes. The more you use Cortana, the more personalized your experience will be. To 

get started, type a question in the search box on the taskbar. Alternatively, select the microphone icon 

and talk to Cortana.  
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Figure 1. 8 CORTANA IN WINDOWS 10 

Cortana provides the following features for users  

 Set Reminders for Times, Places, and people.  

 Use natural language search for files in your computer or search in web.  

 Identify songs: Cortana can listen to a song playing near you and identify it. Say “What is this 

song?” and Cortana will use your microphone to listen to the music and match it to a specific 

song.  

 Search the Web using Bing, google or any search engine you like.  

 Perform calculations and conversion  

 Track flights and packages: Cortana can track flights using the flight number and packages 

using their tracking numbers.  

 Check the Weather: Use Cortana to quickly check the weather in different locations. “Weather” 

will show you the weather at your current location, while “weather in [location]” will show 

you the weather in another city.  

 In addition to many awesome features (set Alarm, get directions, launch programs, send email 

Chat etc...).    

Computer specifications comparison   

When you decide to buy a new PC or laptop, you should be careful about several points and technical 

decision that you will have to make, for instance:  

 How much RAM you will need?   

 Which processor to choose?  

 Which graphics card to pick?  

 What display to look for?  

 Which hard drive will be best for you?  

The sort of applications you will need to run on your PC will help you to decide which feature your 

PC should have.   
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Figure 1. 9 COMPARISON BETWEEN TWO PCS 

 

The upper image shows HP PC, which has 6th generation of i7 processor with clock frequency 3.4GHz, 

and 8 logical cores, while the second HP computer has Core 2 Quad CPU with 2.66GHz clock 

frequency and 4 logical cores. The performance of each processor can be easily determined by 

comparing the feature of each processor.   

 

Random access memory (RAM) of the first PC is 4 GB while the second PC is 8 GB, the more RAM 

is the better, but usually 4GB is more than enough for normal usage,   
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Figure 1. 10 GRAPHIC CARD COMPARISON 

The last screen shoot shows a small comparison between two types of graphic cards (ATI RADEON 

and NVEDIA GeForce), usually Gamers and graphic designers search for high quality graphic cards. 
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1.3 Activities 
1. On your desktop, create a new folder.  

2. Rename the folder to hold your name.  

3. Delete your folder.  

4. Go to Recycle Bin, find your folder there, and restore it.  

5. Create a text file and save it into your folder:  

5.1. Go to start menu, Search for Notepad, click to open.  

5.2. Write in it your name and ID.  

5.3. Go to file, save as, name the file and chose your folder on desktop.  

 

 

  

6. Go to Desktop, open your folder, Copy the file, and paste it on My Documents.  

7. What are the differences between the following?  

7.1. File and Folder.  

7.2. Copy and Cut  

7.3. Cut and Delete  
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Experiment 2: Microsoft Office Word  

 

2.1 Objectives 

 Create and save a document to a specified area. 

 Locate and open an existing document. 

 Move around a document efficiently. 

 Use the mouse and keyboard to select text 

 Add or remove effects such as bold, underline and italic 

 Set the font size style and color. 

 Align text within a document 

 Add a header/footer. 

 Add date, page number, footnote within a document. 

 Preview and print selected pages. 

 Use the Auto Correct function 

 Cut, copy and paste to manipulate text. 

 Use the find and replace function. 

 Differ between undo and redo. 

 Use pictures, symbols, chart. 

 Create and delete tables. 

 Create References, table of content and figures. 

 

2.2 Context 
 

Every day, we discover that we cannot live with computers. One of the important usages of computer 

is dealing with and processing text. In this experiment, we try to make student who is not familiar with 

word processing to be that. In Computer software's world, there is a lot of text processing software, 

but the most popular one is Microsoft Word. 

Microsoft word is one of most software applications that deal with word processing or text processing. 

Every student requires programs dealing with word processing during the educational as well the 

professional life. In this experiment, the student will learn how to work with Microsoft Word 2016, 

and how to be familiar with its environment so the student can perform the text processing work in 

addition to writing reports without asking for help. 

 

Getting Started with Microsoft Word 2016 

In this part students will learn how to enter and insert text. They should be able to open, save and 

reopen saved documents. In order to enrich documents, students can change the appearance of the text 

through different actions. The following are some techniques to be able to manage your documents. 

To Open Microsoft word 2016 (MS Word 2016) click the Start button on your Windows desktop and 

select All Programs and then choose Microsoft office then Microsoft word 2016. 

Exploring the window: 
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The File Button 

In the upper-left corner of the Word 2016 window is the File button. When you click the button, a 

menu appears. You can use the menu to create a new file, open an existing file, save a file, and perform 

many other tasks. 

 

 

The Quick Access Toolbar 

Next to the Microsoft Office button is the Quick Access toolbar. The Quick Access toolbar 

provides you with access to commands you frequently use. By default, Undo and Redo icons 

appear on the Quick Access toolbar. You can use Undo to rollback an action you have taken, 

and Redo to reapply an action you have rolled back. 

 

 The Title Bar  

Next to the Quick Access toolbar is the Title bar. The Title bar displays the title of the 

document on which you are currently working. Word names the first new document you open 

Document1. As you open additional new documents, Word names them sequentially. When 

you save your document, you assign the document a new name. 

 

The Ribbon 

You use commands to tell Microsoft Word what to do. In Microsoft Word 2016, you use the 

Ribbon to issue commands. The Ribbon is located near the top of the screen, below the Quick 
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Access toolbar. At the top of the Ribbon are several tabs; clicking a tab displays several related 

command groups. Within each group are related command buttons. You click buttons to issue 

commands or to access menus and dialog boxes. You may also find a dialog box launcher in 

the bottom-right corner of a group. Clicking the dialog box launcher gives you access to 

additional commands via a dialog box. 

 

 

The Ruler 

The ruler is found below the Ribbon. 

 

You can use the ruler to change the format of your document quickly. If your ruler is not 

visible, follow the steps listed here: 

 

 

1. Click the View tab to choose it. 

2. Click the check box next to Ruler in the Show/Hide group. The ruler appears below 

the Ribbon.  

The Text Area 

Below the ruler is a large area called the text area. You type your document in the text area. 

The blinking vertical line in the upper-left corner of the text area is the cursor. It marks the 

insertion point. As you type, your text displays at the cursor location. The horizontal line next 

to the cursor marks the end of the document. 
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The Vertical and Horizontal and Vertical Scroll Bars 

The vertical and horizontal scroll bars enable you to move up, down, and across your window 

simply by dragging the icon located on the scroll bar. The vertical scroll bar is located along 

the right side of the screen. The horizontal scroll bar is located just above the status bar. To 

move up and down your document, click and drag the vertical scroll bar up and down. To 

move back and forth across your document, click and drag the horizontal scroll bar back and 

forth. You won't see a horizontal scroll bar if the width of your document fits on your screen. 

The Status Bar 

The Status bar appears at the very bottom of your window and provides such information as 

the current page, language and the number of words in your document. You can change what 

displays on the Status bar by right-clicking on the Status bar and selecting the options you 

want from the Customize Status Bar menu. You click a menu item to select it. You click it 

again to deselect it. A check mark next to an item means it is selected. 

 

In Word 2016, you can display your document in one of three views: Web Layout, Print 

Layout, Reading mode.  

1. Web Layout   

Web Layout view enables you to see your document as it would appear in 

a browser such as Internet Explorer. 

2. Print Layout  Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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The Print Layout view shows the document as it will look when it is printed. 

3. Read mode  

Reading Layout view formats your screen to make reading your document 

more comfortable. 

 

Basic Functions in Word 2016 (File Menu): 

 

Create a New Document:  

When you open Word in a new default document called Document1 is created and so 

you can start entering your text immediately but if you want to open another new 

document you can do one of the following ways: 

1. Go to File menu and choose New.  

2. From keyboard press Ctrl + N.      

Entering and Inserting Text:  

After creating your new document, you can start entering your text. The insertion point, or 

cursor, "blinks" at the top of the document where the text you are typing will be displayed. 

When you have entered enough text for one line, the cursor automatically wraps (moves) to 

the next line. If you want to start a new paragraph, press the Enter Key couple of times. You 

can also place the cursor in any location where you want to insert new text. 

Moving Around Document:  

When you want to move through your document you can use one of the following 

methods:  

1.  The cursor in different locations to add text.  

2. Click the Scrollbar to change which part of the document is shown. 

3. Press the arrow keys ← → ↑ ↓on the keyboard to move the cursor through the 

document.  

4. Ctrl-Home / Ctrl-End: moving the cursor to the beginning/end of the 

document. 

5. Page Up / Page Down: moving you to previous/ next page. 

Selecting Text:  

1. Select a paragraph: you can simply triple-click anywhere within the 

paragraph. 

2. Select a Word: you can simply double-click anywhere within the paragraph.  

3. Select all text: to select all features is a quick way to highlight all of the text 

within the entire document. From keyboard press Ctrl+a. 

4. Select text using click + Shift Key: Click to place the insertion point in front 

of the text that you want to select, then press and hold the shift key on your 

keyboard, then click with the mouse pointer at the end of the range of text 

that you want to select. 
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5. Select non-subsequent text using ctrl key: Highlight the text that is to be 

modified then press and hold the Ctrl key on your keyboard, then highlight 

the additional text that is to be modified. 

Moving Text:  

To move text from place to another, select the text you want to move then press and hold 

down the left mouse button over the selected text; then drag the pointer to the new location, 

and release the mouse button to drop the text in that location. 

Saving a Document:   

To save your document: 

1. Form File Button select Save or Save As: for the first time there's no 

difference between them, both allow you to save your document in the place 

you want and the name you choose, for the next times there's a difference. 

Save As: make a new copy from document and leave the original document 

as it while Save: save the currently processing document over the original 

after updated. 

2. From Quick Access Toolbar save icon.  

3. From Keyboard Press Ctrl+s. 

Tip: Word Document Extension 

Word documents usually saved with extension doc (*.doc), you can save 

your document with another extensions such as html, txt…etc 

 

Closing a Document:  

To close your document, you can follow one of these ways: 

1. Click the Close  button in the document window. If you have edited the 

document since saving it last, Word asks whether you want to save it, click 

the Yes button to save your changes, and the document will close. 

2. From File Button select Close. 

TIP: Close and Exit 

There is a difference between Close and Exit commands. Close means that 

you want to close the document you working on but you want to keep 

Microsoft Word 2016 running. While Exit close both the document and the 

program.  

Opening a Document:  

To open a preexisting document, you can do one of the following: 

1. From File Button Menu select Open. 

2. From Quick Access Toolbar open icon   

3. From Keyboard Press Ctrl+o. 

Previewing and printing a Document: 
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It's always better to check your document before you print it, print preview command 

enable you to see how pages in document will be look like and let you do your 

formatting instead of doing a lot of printing and waste many papers and ink. To 

preview your document: 

1. From File Button select Print. 

2. From Quick Access Toolbar preview and print icon   

3. From Keyboard Press Ctrl+P. 

Word makes printing a document easy and enables you to select the printer and font settings. 

You can print the whole document, a single page, specific page ranges, specific separate 

pages, or selected text. You can also specify the number of copies to print and collate the 

copies as you print.  To print your document, do one of the following:  

 

Sharing a Document: 

In Word 2016 for Windows, it's easier than ever to share your documents. When you share 

your files using OneDrive or Office 365 SharePoint, you can invite people to the document 

from right within Word, or send a PDF or Word file as an email attachment. Toshare your 

document: 

1. From File Button select Print. 

2. From Quick Access Toolbar select share    

 

 Editing Document  
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There are many ways to edit documents. You can cut, copy, or paste text or objects, or overwrite 

them. Making mistakes in Word is not a big deal, you can undo these changes and if you change 

your mind you can redo them. 

Finding and replacing text can be so hard, searching the document by you or replacing Word by 

Word is not an easy job especially if we talk about large documents, grammar and spelling 

mistakes need to be correct, in this part you will be able to do all these things easily without 

needing so much time. 

Cut, Copy and Paste:  

         It’s important to understand the difference between cut and copy. When you cut text, you 

remove it from its original location and place it in a new location. While copying text makes a 

duplicate text that can be placed in a new location, the original text remains in its primary location. 

Paste simply places the text you cut or copied in the new location that you specified. To apply 

these in Ms-Word Highlight the text to do the following: 

1. Cut: 

 From Clipboard group in Home tab use   , or use Ctrl+x, or after right-

click select Cut from context menu. 

2.Copy:  

 From Clipboard group in Home tab use   , or use Ctrl+c, or after right-

click select Copy from context menu. 

3.Paste: 

 From Clipboard group in Home tab use , or use Ctrl+v, or after right-click 

select Cut from context menu. 

 

 

 

Overwriting or delete:  

          Sometimes you will need to modify or delete text in a document. You can do these by many 

ways but the easiest is to overwrite text or delete it with the Delete command. Overwriting replaces 

the existing text with new text as you type while deleting completely removes the text from the 

document. 

1. Overwrite: 

 Highlight the text that you want to overwrite. 

 Start entering the new text. 

TIP: When Cut, Copy, Paste be inactive 

For the first time when you open MS-word 2016 document to begin 

processing, cut, copy and paste will be in inactive state. Copy and cut convert 

to active state when the text highlighted. After select copy or cut, paste 

becomes active too.  

When cut, copy, and paste comeback to inactive state? 

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

22 

2. Delete: 

 Highlight the text that you want to delete. 

 Press the delete key from keyboard. 

TIP:  Backspace and Delete 

You can use either backspace or delete to remove text completely from your 

document. Backspace key delete characters to the left of the insertion point while 

the Delete key delete characters to the right of the insertion point. 

 

Undoing and Redoing Changes:  

          Word provides an easy way to undo or reverse many of the actions you made. It also 

provides an easily way to redo actions that you have been recently undone. 

1. To Make Undo you can do one of the following: 

 From Undo icon on quick access toolbar.  

 Or from keyboard use Ctr+z. 

2. To Make Redo you can do one of the following:  

 From Redo icon on quick access toolbar.  

 Or From keyboard Ctrl+y. 

TIP: Undo/ Redo More than One Action 

To Undo or Redo more than one action you can repeat the command or simply click 

the arrow that appear next to Undo/ Redo and choose from the list the actions that 

you want to Undo or Redo. 

Finding Text:  

          When you are working with a long document it can be time consuming to find a specific 

word or words. The find feature will help you locate specific text within document. To 

find a specific text, you can use one of these methods: 

1. From Editing group in Home tab select Find , In the Find what field, type 

the word you want to locate. Click Find Next button until you locate the 

appropriate occurrence of the word you are searching for.  

2. Or Ctrl+f from keyboard, In the Find what field, type the word you want to 

locate. Click Find Next button until you locate the appropriate occurrence of the 

word you are searching for.  

Replacing Text:  

           Similar to the find feature, the replace feature will perform a search for a specific word 

and replace it with another word. To replace a specific text, you can use one of these 

methods: 

1. From Editing group in Home tab select Replace , In the Find 

what field, type the word you want to replace and in Replace with field Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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type the word that you want to use as a replacement. Click Find Next 

button until you locate the appropriate occurrence of the word you are 

searching for.  Click Replace button if you want to use the replacement 

word instead. Click Replace All button to replace all matching words.  

2. Or CTRL+F from keyboard, In the Find what field, type the word you 

want to replace and in Replace with field type the word that you want to 

use as a replacement. Click Find Next button until you locate the 

appropriate occurrence of the word you are searching for.  Click Replace 

button if you want to use the replacement word instead. Click Replace 

All button to replace all matching words.  

TIP: Replace All  

Replace All Button can be very helpful, but sometimes the replace all button will 

prompt MS-word to replace variations in the document that might not have occurred 

to you. For example, if you try to replace "Form" with "From", words such as 

"Formula" will become "Fromula" and "Transform" will be "TransFrom".  

 

Using Autocorrect Options:  

         AutoCorrect corrects common errors as you type, such as misspelled words and 

incorrect capitalization. When you install MS-word the AutoCorrect feature is turned 

on by default. AutoCorrect includes many default entries that represented a list of 

common typing errors. To use Autocorrect do the following: 

1. Click the File button 

2. Select Word Options 

3. Click Proofing in the left pane 

4. Click the AutoCorrect Options button 

5. Select the AutoCorrect tab. 

6. Examine the check boxes. 

7. Scroll down and examine the default entries listed under Replace and with. 

This list represents commonly used symbols and typing mistakes. 

8. If you consistently make an error that is not included in the list, you can create 

a custom entry. In the Replace field, type the word you often misspell. 

9. In the with field, type the correct spelling of the word and click the add button.  

10. Click Ok. Now when you type the word incorrectly, Ms-Word will 

automatically replace it with the customized correction. 

Checking Spelling and Grammar:  

         You may search the document for the spelling and grammar errors. When MS-Word 

finds a possible error, you can correct it and continue your search. To check spelling 

and grammar in your document follow the steps below: 

1. Click to place the insertion point at the beginning of the document.  

2. Click the spelling and grammar button  in the Proofing group in Review 

Tab. This will open MS-Word's dictionary and automatically begin searching 

for possible spelling and grammatical errors. 

3. If MS-Word flags something that is correct, click Ignore Once to force the 

spell check to proceed to the next potential error or Ignore All which will skip 

every instance of the word in the document. 
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4. To correct a spelling error, click on the correct spelling from the list of 

suggestions and then click Change. You may also type in your own changes in 

the top window within the Spelling and Grammar dialog box and click Change. 

5. To close the dictionary, click the close Button. 

 

Formatting Text 

There are many ways to format documents in Microsoft Word. For example, you can change the 

font, font size, and font color; highlight the text; add a border, shade the background, adding 

bulleted lists, numbered lists, and indenting text.  

This part will show many tools that will make your text nice and well arranged. 

Changing Text Font, Size, color, and Shading: 

 A font is a set of all characters available in one typeface and size, including uppercase 

letters, lowercase letters, punctuation, and numerals. To change the appearance of text, 

you may change the font as well as font style. Be sure to choose a font that is legible 

and practical. To change do as shown below: 

1. Highlight the text that is to be modified. 

2. After right-click select Font from context menu. 

3. Specify the font typeface, size and color and then click ok. 

You can also change the font Typeface, size, and color from Font group in home tab 

by using the following icons. 

       
 

Applying Bold, Italic and Underline:  

You can change also font style (Bold, Italic, Underline) as shown below: 

1. Highlight the text that is to be modified. 

2. After right-click select Font from context menu. 

3. Specify the whether you want it italic, bold, underline and then click ok. 

You can also change make this from Font group in home tab by using the 

following icons.   Where B: Bold, I: italic and U: underline 

Applying Font Effects: 

 

From Font group in home tab by using the following icons.   

 Which: 

 abc: Draw line through the middle of the text. 

 X2
: subscript (create small letters below the text base line). Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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 X2: subscript (create small letters above the text base line). 

 

Copying Formatting:  

If you want to copy character formatting this tool will be very helpful.  

1. Highlight the text that contains the formats you want to copy. 

2. Click the format Painter button in the standard toolbar.  

3. Click, hold and drag the paintbrush mouse pointer over the text you want to 

format. 

 

Formatting paragraph 

Changing Alignment:                   

 To change alignment, Highlight the text that is to be modified and Click the desired 

alignment button: 

1. Align Right : with right alignment the right side of the paragraph is aligned 

with the right margin or indent. 

2. Align Left : Left alignment is word's default alignment for body text. The 

Left side of the paragraph is aligned with the right margin or indent. 

3. Center : with center alignment, each line of paragraph is centered 

between the left and right margins or indents. 

4. Justify : with justified alignment the paragraph is aligned with both the 

left and right margins or indents. 

Adding Numbers and Bullets Lists:  

1. Select the words you just typed.  

2. Choose the Home tab. 

3. In the Paragraph group, click the down arrow next to the Bullets button  

or numbering . The Lists Library appears. 

4. Click to select the type of style you want to use. Word adds styles to your 

list. 

Note: As you move your cursor over the various Lists styles, Word displays 

the bullet style onscreen. 

 Change paragraph indent, direction, line spacing, shading, and border: 

 You can also change all of the above from Paragraph group in home tab by using the 

following icons. 
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Formatting Documents 

There are many techniques for formatting document in Microsoft Word. For example, pictures, 

symbols, charts and other objects can be inserted to enrich documents, you can also insert a page 

break and start text on a new page, insert a section break and have double columns in your 

document, in addition to these formatting techniques; you can change your page margins.  

Furthermore, finishing touches, such as page borders, page numbers, headers and footers…etc, can 

be used to enhance your document. 

Insert pages 

From Insert tab you can insert:   

1. cover page: fully formatted cover page, you fill the title author, date, and 

other information.  

2. blank page: insert a new blank page in the courser position  

3. Page break:  star the next page at the current position of the courser. To force 

text to be on the top of the following page, you may insert a manual page 

break. As you edit the document, you may have delete and reinsert page 

breaks depending on the flow of text. It may be helpful to wait until you are 

in the final stages of formatting your document. To insert manual page 

break: 

 
Tables: 

 A table is a grid that is made up of columns and rows. The intersection of a column 

and a row is called a cell. Gridlines are the lines within the table that separate each 

column and row. Tables are much more effective than tabs for aligning information in 

columns and rows. 

1. To Insert Table: 

 From the Insert tab, trace to table and select Insert table. 

 Specify the Number of columns and Number of rows. 

 Click OK. 

 

2. Insert a Row or Column: 

 Select row or column. 

 Right click on mouse then select to Insert and select one of the following 

(Table, Columns, Rows, or Cells). 

 

Note: you can insert by Click to place your insertion point where you want to insert a 

row or column. Then Click on plus icon to insert row and column in certain place.  
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3. Delete a Row or Column 

 Select row or column. 

 Right click on mouse then select to Delete and select one of the following 

(Table, Columns, Rows, or Cells). 

 

4. Table Design  

Select the table then use the Table Design Tab to change the Table Style  

 

5. Text Direction 

 The text direction command will change the orientation of text within a cell. 

 Right-click the cell and select Text Direction. 

 Click to select the desired Orientation. 

 Click OK. 

 

6. Merging Cells 

 The merge cells command will combine multiple cells into one cell. 

 Select the cells you want to merge together. 

 From the Table menu, select Merge Cells. 

 

Note: table can be inserted to the document in many ways, one by menu, and another 

by drawing table’s icon. 

Insertions 

Inserting Picture:  

1. Insert Picture from File:  

 Click where you want to insert the picture in your document. 

 From Insert tab go o Illustration group and click Insert picture Icon.   

 Navigate to the folder or disk drive where the image is stored and then click to select the 

picture you want to insert and click insert. 

   Now try to resize your picture and move it to another place, can you? 

2. Insert online Picture: inserting a picture from an online source like Bing. 

 Click where you want to insert the picture in your document.  
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 From Insert tab go o Illustration group and click Insert Online Pictures.  

 In the Bing Image Search box, type a word or phrase that describes the picture you're 

looking for, and then press ENTER. 

 
 In the list of results, click an item, and then click Insert. 

Inserting Date:  

1. Click to place the insertion point where you want to insert the date. 

2. From Insert tab, select Date and Time from text group.  

3. Click to select one of the desired available formats. 

4. If you want the date to be automatically updated to the current date each time you open 

the document, click to select the Update Automatically Checkbox, and then click Ok. 

Inserting Symbols:  

The Symbol command enables you to insert special characters, international 

characters, and symbols such as the registered trademark (®) and trademark (™) 

symbols. You can easily add these and other special characters to your Word 

documents. 

1. Click to place the insertion point where you want to insert the date. 

2. From Insert tab, select Symbol from Symbols group.   

3. Double-click the symbol you want to insert into your document then Close. 

Inserting Equations:  

The Equation command enables you to insert Equation: 

1. Click to place the insertion point where you want to insert the date. 

2. From Insert tab, select Equation from Symbols group.   

3. Select insert equation then type a math equation. 

4. Or Select a Ink equation to hand write a math equation. 

 

Insert WordArt: 

WordArt can be added to your document using a button on the Insert command tab.  

1. From the Insert command tab, in the Text group, click  
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The WordArt Gallery dialog box appears. 

 

 

2. From the WordArt Gallery, select the desired style 

The Edit WordArt Text dialog box appears. 

3. In the Text box, type your text 

4. To format your text, from the Font or Size pull-down lists, make the desired 

selections 

5. To change the font style, click BOLD or ITALIC 

6. Click OK, your WordArt is placed in the document and the Format command 

tab appears. 

Insert Shape: 

1. On the Insert tab, in the Illustrations group, click Shape.  

2. In the Choose a Shape Graphic gallery, click Hierarchy, click a shape and then 

click OK. 

Insert Smart Art: 

1. On the Insert tab, in the Illustrations group, click SmartArt.  

2. In the Choose a SmartArt Graphic gallery, click Hierarchy, click a Smart art 

and then click OK. 

To add your text to the chart objects, do one of the following:  

 Click in a shape in the SmartArt graphic and type your text. 

 Click [Text] in the Text pane and type your text. 

 Copy text from another location or program, click in the Text pane, and 

paste your text. 

Insert Chart: 

1. On the Insert tab, in the Illustrations group, click Chart.  

2. In the Choose a Chart Graphic gallery, click Hierarchy, click an organization 

chart layout (such as Column Chart), and then click OK. 

To add your text to the chart objects, do one of the following:  

 Click in a shape in the SmartArt graphic and type your text. 

 Click [Text] in the Text pane and type your text. 

 Copy text from another location or program, click in the Text pane, and 

paste your text. 

Insert Screenshot: 

         Screenshots are useful for capturing snapshots of information that might change or expire 

On the Insert tab, in the Illustrations group, click Screenshot. 
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When you click the Screenshot button, you can insert the whole program window or use the 

Screen Clipping tool to select part of a window. Only windows that have not been minimized 

to the taskbar can be captured.  

When you choose Screen Clipping, your entire window will temporarily become opaque or 

“frosted over”. After you select the part of the window that you want, your selection will show 

through this opaqueness. 

Open program windows are displayed as thumbnails in the Available Windows gallery and 

when you pause your pointer over a thumbnail, a tooltip pops up with the program name and 

document title. 

Insert Online Video: 

To find and insert then online video from media YouTube or Bing. 

1. On the Insert tab, in the Media group, click Online Video.  

 

2. In the Bing Image Search box, type a word or phrase that describes the picture you're 

looking for, and then press ENTER. 

 

3. In the list of results, click an item, and then click Insert. 

 

Insert a Hyperlink:  

Hyperlinks are words, icons, pictures, or other graphics that are used to navigate the 

Web. A hyperlink can take you to another location on the same Web page or to a 

different Web page. 

1. Highlight the text you want to make a Hyperlink. 

2. From the Insert tab in links group select Hyperlink.  

3. In the insert Hyperlink window, click to select Existing File or Web Page. 

4. In the Text to display field, verify the test you highlighted appears (this is the 

text in 

5. The document you want to associate the link to. 

6. In the Address field, type the address of the Web page to which you want to 

link. 

7. Click OK. The text within the document will change color and become 

underlined in order to be a recognizable link. 
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Use Hyperlinks 

To use a hyperlink, the mouse pointer must become an icon of a pointing finger when 

it is placed directly on the link. If you insert hyperlinks into your document, you will 

need to educate your audience so they will know how to activate them. 

1. Press and hold the Ctrl key on your keyboard and click the hyperlink 

simultaneously. 

2. The linked file will open in its source application. After you click the hyperlink 

the color of the hyperlink changes indicating it has been used. 

Insert a Bookmark:  

A bookmark identifies a specific word, section, or place in your document so you can easily 

find it again without scrolling through the document. For example, you might create a 

bookmark to identify text that you want to revise later. 

To add a bookmark, you first mark the location in your document you want to go to. After 

that, you can jump to the location or add links to it within your document. To insert 

Bookmark: 

1. Select text, a picture, or a place in your document where you want to insert a 

bookmark. 

2. Click Insert select Bookmark.  

3. Under Bookmark name, type or select a name and click Add. 

Go to the bookmark 

After creating your bookmarks, you can jump to them at any time or add links to them 

within your document. 

4. Type Ctrl+G to open the Go To tab in the Find and Replace box.  

5. Under Go to what, click Bookmark, select the bookmark name, and then click Go 

To 

 

Inserting Header and Footer:  

1.On the Insert tab, in the Header & Footer group, click Header or Footer. 
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2.Click the header or footer design that you want. 

 

Change the Header or Footer for Part of the Document 

You may use the same header and footer throughout a document or change the header 

and footer for part of the document. For example, you may want a unique header or 

footer on the first page of a document, or to use different headers and footers on odd 

and even pages. 

1. First page: 

 On the first page of the document, double click the header or footer area. 

 Under Header & Footer Tools, on the Design tab, in the Options group, 

select the Different First Page check box. 

 Create a header or footer, or make changes to the existing header or footer, 

on the first page. 

2. Odd and even pages: 

 Double-click in the header or footer area. 

 Under Header & Footer Tools, on the Design tab, in the Options group, 

select the Different Odd & Even Pages check box. 

    Note: The existing header or footer is now configured for odd-numbered pages only. 

3. Under Header & Footer Tools, on the Design tab, in the Navigation group, 

click Next Section to advance the cursor to the header or footer for even-

numbered pages, and then create the header or footer for even-numbered pages. 

Inserting Page Numbers:  

1. On the Insert tab, in the Header & Footer group, click Page Number  

2. Click Top of Page or Bottom of Page, depending on where you want page 

numbers to appear in your document. 

3. Choose a page number design from the gallery of designs.  

 Design page 

 

Add Watermark:  

A watermark is text or a picture that appears behind the text in a document. Watermarks 

are often used to add graphics to document without obscuring or taking room away 

from text. 

From the Design tab in page background groups press watermark and select 

Custom watermark. 
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1. To insert a picture as a watermark:  

 Click the Picture Watermark radio button. 

 Click Select Picture button. 

 Navigate to the folder or disk where the image is stored. 

 Click to select the picture that you want to insert. 

 Click Insert. 

 Click Ok. 

2. To insert text as watermark: 

 Click the Picture Watermark radio button. 

 Click Select Text button. 

 Enter the text that you want to include as a watermark. 

 Select any additional desired options (Font, Size, or Color). 

 Under Layout, specify if you want the watermark to be Diagonal or Horizontal. 

 Click Ok. 

 

 

 

 

Add Page Color: To add a Color for the whole page:  

1. From Design tab in Page Background groups select Page Color 

2. select the desired color.  

Add Page Border:  

To add a border for the whole page:  

1. From Design tab in Page Background groups select Page Border 

2. Click to select the desired setting, style, color and width …etc.  

3. In the preview pane, verify your selections and then click Ok. 

Page Layout  

Inserting Section Break:  

Sometimes sections of long documents must be formatted differently. In order to setup 

different formatting for different parts of the document, you must divide the document 

into sections. A section is all of the text between section breaks. To break a document 

into multiple sections:  

1. Click to place the insertion point where you want to insert the section break. 

2. From the Page Layout tab in page setup groups select Break. 

3. Under section break types, click the option that describes where you want the 

new section to begin: 

 Next Page: inserts a section break and start a new section in the next page. 

Tip: Viewing Watermark 

To see watermark you must be sure that your document is in Print 

Layout View. 
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 Continuous: inserts a section break and start a new section on the same 

page. 

 Even / Odd Page: insert a section break and start a new section on the next 

Even / Odd numbered page. 

4. Click Ok. 

Tip: Deleting a section Break  

Formatting is stored in section breaks. When you delete a section break, you also 

delete the section formatting for the text above the (deleted) section break. As a 

result, text becomes part of the following section and assumes the formatting of 

that section when a section break is removed.  

1. Click the Show/Hide button in the standard toolbar.  

2. Move the insertion point to the line below the section break code. 

3. Press the Backspace key on your keyboard. If the insertion point is 

positioned in front of the section break code, press the Delete key 

on your keyboard. 

4. Click the Show/Hide button again, to hide the codes.  

 

Adding Columns: 

1. Highlight the text that is to be formatted in columns. 

2. From the Page Layout tab in page setup groups press Columns and select 

more columns.  

3. Click to select the desired Number of Columns or enter the number of 

columns. 

4. Enter the desired column Width and Spacing between columns. 

5. If you want a line between the columns, click the line between checkbox. 

6. Click Ok. 

Setting Page Margins:   

You can adjust the top, bottom, left, and right margins for a single page or for your 

entire document. For example, you might need to fit a large amount of text on one page 

and therefore need to increase the margins for the document's printable area. To set 

your document margins: 

1. From the Page Layout tab in page setup groups press Margins and select 

Custom Margins.   

2. Type the new margin settings (for example, 1 inch in the Left spin box and 1 

inch in the Right spin box). 

3. Click the OK button. 

Citation  

A citation is an entry of text that tells your reader where you got your information. Information like 

the author’s name, the date of publication, the title of the document, page numbers, publishing 
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information, what edition the source is, and a URL are often part of this entry. Essentially, your reader 

should be able to find your source on their own from the information in the citation. 

WHEN DO I NEED TO CITE MY SOURCE? 

Plagiarism is using another author’s words, ideas, or work in print or speech as if they were your own. 

An author’s original thought is protected as intellectual property under United States’ copyright law, 

so plagiarism is essentially an act of fraud. To avoid plagiarism, you need to cite your source whenever 

you use anything you are borrowing from someone else. This includes using someone else exact 

wording, paraphrasing, an idea from another author, or even using a similar sentence structure.  

According to plagiarism.org, these are also considered plagiarism:  

 failing to give credit when using or copying words or ideas from another author, including 

neglecting quotation marks  

 giving inaccurate source information  

 using so many words or ideas from another source that it makes up most of your work – whether 

you give credit or not 

 
 References the documents  

Now that you know how to edit documents, format text, and format your documents, it is time to 

do a little advanced work in Microsoft Word. In this part you will learn how to insert tables inside 

your document, create a table of content to your document and finally how to protect it. 

Build a Table of Contents 

To create a table of contents, you must apply heading styles (Heading 1 through 

Heading 9) to the headings that you want to include in the table of contents. Once you 

have applied the heading styles, you can build a table of contents. 

To apply built-in heading styles: 

 

1. Highlight the text that is to be included in the table of contents (topic heading, 

topic subheading, chapter title, etc.). 

2. Apply a Heading Style (Heading 1 through Heading 9) from the Styles 

dropdown list in the Home tab. 

3. Continue following steps 1 and 2 throughout the entire document applying a 

heading style (Heading 1 through Heading 9) to the text you want to include 

in your table of contents. 

 

 

To Build the Table of Contents: 
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Click to place the insertion point where you want to insert the table of contents. 

From the References tab, trace Table of Contents, and click Insert Table of Contents. 

Click the Table of Contents tab. 

Click to select additional options (Show page numbers, Right align page numbers, Tab Leader format, 

etc.). 

In the Print Preview Pane, verify your selections. 

Click OK. 

Update a Table of Contents 

When you add or remove text or add and remove manual page breaks, the flow of the 

text on each page is subject to. As a result, you may need to update the table of contents 

to reflect changes to the pagination. 

1. Place the mouse pointer directly on the table and contents, right-click 

and select Update Field. 

2. Click to select one of the following: Update page numbers only or 

Update entire table. 

3. Click OK. 

Build a Table of Figures 

To create a table of Figure, you must add captions for each photo in the 

document. From References select insert captions icon. then type picture 

name as bellow then press ok. 

Once you have applied the Captions for all Figure. you can build a 

table of Figure. 

To Build the Table of Figures: 

1. Click to place the insertion point where you want to 

insert the table of contents. 

2. From the References tab click Custom Table of Figures. 

3. Click OK. 

Update a Table of Figures  

When you add or remove text or add and remove manual page breaks, the flow of the 

text on each page is subject to. As a result, you may need to update the table of figures 

to reflect changes to the pagination. 

1. Place the mouse pointer directly on the table and contents, right-click and 

select Update Field. 

2. Click to select one of the following: Update page numbers only or Update 

entire table. 

3. Click OK. 

 

Insert Endnote and Footnote 

Footnotes and endnotes are used in printed documents to explain, comment on, or 

provide references for text in a document. You might use footnotes for detailed 

comments and endnotes for citation of sources. 

1. click where you want to insert the note reference mark. 

2. On the References tab, in the Footnotes group, click Insert Footnote or Insert 

Endnote. 

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

37 

 

Insert Citations and Bibliography  

A bibliography is a list of sources, usually placed at the end of a document, 

that you consulted or cited in creating the document. In Microsoft Office 

Word 2016, you can automatically generate a bibliography based on the 

source information that you provide for the document. 

Each time that you create a new source, the source information is saved on your computer, so 

that you can find and use any source you have created. To add a new citation to a document, 

you also create a new source that will appear in the bibliography 

1. On the References tab, in the Citations & Bibliography group, click the arrow next to 

Style. 

2. Click the style that you want to use for the citation and source. 

3. Click at the end of the sentence or phrase that you want to cite. 

4. On the References tab, in the Citations & Bibliography group, click Insert Citation. 

5. Do one of the following: 

 To add the source information, click Add New Source. 

 To add a placeholder, so that you can create a citation and fill in the source information 

later, click Add new placeholder. A question mark appears next to placeholder sources in 

Source Manager. 

6. Begin to fill in the source information by clicking the arrow next to Type of source. 

7. Fill in the bibliography information for the source. 

Create a bibliography 

You can create a bibliography at any point after you insert one or more sources in a document. 

If you don't have all of the information that you need about a source to create a complete 

citation, you can use a placeholder citation, and then complete the source information later. 

1. Click where you want to insert a bibliography, usually at the end of the document. 

2. On the References tab, in the Citations & Bibliography group, click Bibliography. 

3. Click a predesigned bibliography format to insert the bibliography into the document. 

Footnotes and endnotes 

The Merriam-Webster Online Dictionary defines a footnote as a note of reference, explanation, 

or comment usually placed below the text on a printed page. Footnotes are indicated by consecutively-

numbered superscript Arabic numbers in the main text after the punctuation of the phrase or clause. 

Footnotes appear at the bottom of the page on with the superscript reference mark. A footnote can also 

have an associated citation at the end of the footnote text. Endnotes appear at the end of the document. 

 In each style, a reference mark appears in the body of the text, and a reference note (either a 

footnote or an endnote) containing a matching reference mark is used to document the reference 

Adding footnotes or endnotes 

Adding a footnote is a two-step process 

 Step 1: Adding the footnote reference mark in the body of the document 
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Place the cursor at the exact point in the sentence where the footnote reference mark 

should appear, after the punctuation.  On the References tab, in the Footnotes group, click the 

Insert Footnote button. This places two reference marks. One reference mark is at the cursor 

position in the body of the document; the other reference mark is in the footnote area at the 

bottom of the page. 

 

 

FIGURE 2. 1 INSERT FOOTNOTE 

 

Step 2: Adding the footnote “text”. 

When the reference mark is inserted into the body of the document, a placeholder for 

the footnote text is created at the bottom of the page on which the footnote should appear. To 

add the reference text into the footnote, click in the footnote placeholder and enter the desired 

text.   

 

FIGURE 2. 2 ADD FOOTNOTE TEXT 

To add another footnote, Repeat the How to add a footnote procedure above to add additional 

footnotes. To add an endnote, click the Insert Endnote button on the References tab and follow a similar 

procedure to adding a footnote. Endnotes and footnotes are handled the same within Word 2016, the 

only difference is the placement of the reference wording 

 

Insert Footnote 

after word “text”, 

and before the 

period 
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Change the note number format 

If you find that you need to change the number formatting style that is automatically applied to the 

footnote or endnotes text, you can do so after creating the notes. 

1. On the References tab, in the Footnotes group, click the dialog box launcher (the small arrow 

in the lower right corner of Footnotes group) 

2. Click either Footnotes or Endnotes from the location area at the top of the dialog box. 

3. In the Number format area, select the format you want to use from the drop down list of choices 

and click the Apply button.  

 

FIGURE 2 3 THE FOOTNOTE AND ENDNOTE DIALOG BOX 

Change the footnote or endnote separator 

If you need to change the footnote or endnote separator (the line above the reference text) or want 

to remove it completely, follow the steps listed below:  

1. On the View tab, in the Document Views group, click Draft. 

2. On the References tab, in the Footnotes group, click Show Notes. 

a. If you used only footnotes in the document, this will open the Footnotes pane. 

b. If you used only endnotes in the document, this will open the Endnotes pane. 

c. If you used both footnotes and endnotes in the document, choose one of the reference areas 

to edit (View footnote area or View endnote area) in the dialog box that appears and click 

the OK button. 

3. In the dropdown list in the foot notes / endnotes pane, select either the Footnotes Separator or 

Endnotes Separator depending on which one you want to modify or remove.  

4. Delete the separator line, add in your own line, or leave the separator blank.  

5. On the View tab, in the Document Views group, click Print Layout.  

 

 FIGURE 2. 4 EDIT FOOTNOTE AND ENDNOTE 
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Select (highlight) the footnote reference mark in the body of the document and press the Delete 

key. This will delete both the footnote/endnote reference mark in the body of the document and the 

associated footnote/endnote at the bottom of the page. 

 

Browsing footnotes and endnotes 

In lengthy documents with a large number of footnotes and/or endnotes, locating the reference 

marks in the document can be a challenge. Using the option available on the Ribbon, you can quickly 

navigate among the many reference marks in the document. To browse footnotes and endnotes, follow 

these steps: 

1. Click anywhere in the beginning of the document. 

2. On the References tab, in the Footnotes group, click the arrow to the right of the Next Footnote 

option. 

3. In the drop down list, click the appropriate choice based on where you clicked in the document 

and the reference mark you are trying to locate. 

4. The cursor moves into the document in the position of the footnote or endnote. Continue to 

click the Next option until you locate the necessary reference mark.  

 

FIGURE 2. 5 BROWSING FOOTNOTES AND ENDNOTES 

Captions 

When adding images, tables, and other objects in your documents it is a good idea to label the 

objects with captions and reference them at some point in the document text. Although you can 

complete these tasks manually, time is wasted updating references if the caption numbers change after 

adding or deleting images. Word has built-in automatic features to handle both these tasks. 

 

Inserting figure numbers and captions 

A caption is a numbered label inside a text box, such as Figure 1, that you can add to a figure, a 

table, an equation, or another object. If you later add, delete, or move captions, you can easily update 

the caption numbers all at once. To add captions to document objects, follow these steps: 

1. Open a document that contains the object (image, table, etc.) you want to label or add one to 

an existing document. 

2. Click once on the object to select it. Then, either: 

a. Right click the object and choose Insert Caption from the context menu. –OR – 

b. On the References tab, in the Captions group, click Insert Caption. 

 

FIGURE 2. 6 FIGURE CAPTION 

3. In the Label list, select the label that best describes the object, such as a picture or equation In 

the Caption area, type any text, including punctuation that you want to appear after the label. 

4. Select any other options you want from the Position list or the Numbering button. 
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5. Click the OK button when finished and the label is added to the object. Repeat steps 2-5 to add 

captions to any other objects in the document. Word will automatically number each additional 

caption. 

6. To change any text inserted into a caption simply click once inside the caption and add or 

remove the necessary text. 

 
FIGURE 2. 7 CAPTION WINDOW 

Deleting captions 

You can quickly remove a caption from an object and then renumber the remaining captions to 

reflect the change. To delete a caption, follow these steps: 

1. Determine if the caption is inside a text box or in-line with text.  

2. Captions on images: Left click once inside the caption to activate the text box. Right click on 

the border of the caption (see the blue dotted line in Figure 13). Click Cut in the context menu 

that appears. 

3. Captions on tables and equations: Simply drag across the selected text to highlight it and press 

the delete key on the keyboard. 

4. If necessary, update the remaining captions in the document to reflect the deletion (see the 

section below). 

 

Updating caption numbering 

If you insert a new caption, Word automatically updates the caption numbers. However, if you 

delete or move a caption, you must manually update the captions. To update caption numbering, follow 

these steps: 

1. Select a caption or captions to update. Do one of the following: 

a. To update a specific caption, select it. 

b. To update all captions, click anywhere in the document and press Ctrl+A to select the entire 

document.  

2. Right-click, and then click Update Field in the context menu that appears.  

Changing the caption style 

The applied formatting for all captions in the document is based on the Caption style. For example, in 

the sample caption labeled Figure 1found in Figure 13above, the text is Times New Roman, bold, blue, 

and 9 point. You can change the applied caption style by following these steps: 

1. On the Home tab in the Styles group, click the dialog box launcher. 

2. In the list of available styles that appears in the Styles task pane, point to Caption, then click 

the small black down arrow at the right end of  

3. Click the Modify... (see Figure 14) option in the list of available choices. 

4. In the Formatting area, change the font face, size, color and style. The changes made in this 

area will automatically be reflected in all captions currently used in the document and any new 

ones you insert. 
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5. Click the OK button to apply the new caption formatting to the current document.  

 

 
FIGURE 2. 8 UPDATE CAPTION STYLE 

Creating a table of figures 

To create a Table of Figures:  

1. Place the cursor after the word FIGURES.  

2. From the References tab, from the Captions group choose Insert Table of Figures. 

3. In the Table of Figures dialog box:  

 Check Show page numbers  

 Check Right align page numbers  

 Uncheck Use hyperlinks  

 Tab leader = dot (......) 

 

FIGURE 2. 9 TABLE OF FIGURES OPTIONS 

4. Under Caption labels, choose None. In this case, we want our Figures list to include any 

potential figures in the appendices — searching by label will only return figures in the main 

body of the text. 

5. Click the Options button, check Style, and then select Figure Caption  

6. Click OK, then OK again.  

7. Save the file. 

 

Citations and bibliography 

If you need to write a research paper, chances are you'll also be required to include a 

bibliography. Or you might be asked to include a works cited page or a list of references. These are 

all just different names for the same thing: a list of sources—such as books, articles, or even 

websites—that you used to research and write your paper. A bibliography makes it easy for someone 

else to see where you found your information. 

Choose a reference style 

When you're creating a bibliography, you'll need to follow the guidelines of the required style guide. 

Different academic disciplines use their own styles guides, such as MLA, APA, and Chicago. 

Fortunately, Word comes with several built-in style guides; all you need to do is select the one you 

want to use, and Word will help you format your bibliography correctly. 

To do this, click the References tab, then select the desired style in the Citations & Bibliography 

group. 
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FIGURE 2. 10 REFERENCE STYLE 

Add citations and sources 

Whenever you use information from one of your sources, you'll need to give credit—or cite them. This 

is known as making a citation. You'll include citations whenever you use information from a source or 

when you quote a source directly. 

To add a citation, select the desired location for the citation in your document, click the Insert Citation 

command on the References tab, and select Add New Source. 

 

FIGURE2. 11 ADDING NEW REFERENCE SOURCE 

A dialog box will appear. Enter the requested information for the source—like the author name, 

title, and publication details—then click OK. 

 

FIGURE 2. 12 REFERENCE DETAILS WINDOW 

The citation will appear in the document, and the source will be saved. You can quickly add another 

citation for the source by clicking Insert Citation and selecting the source from the drop-down menu. 
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Editing source information 

Editing that is already in the source management database is very easy.  

Open the source management database. On the References tab, in the 

Citations & Bibliography group, click on the Manage Sources button to 

open the Source Manager dialog box. 

 

For this example, let us assume that the publishing date for the book 

Medical Humor by Doe was incorrect. Instead of 2009, it should be 

2005. 

 
This will display the Edit Source dialog box, which allows editing the publication date of the 

source. Edit the Year field, then click the OK button. 

 

FIGURE 2. 13 EDIT REFERENCES 

Insert the bibliography 

Once you have added all of your sources, you can create your bibliography in just a few clicks! 

Just select the Bibliography command, then choose the desired style. 

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

45 

 

FIGURE 2. 14 INSERT BIBLIOGRAPHY 

The bibliography will appear at the end of your document. Your sources will already be 

formatted to match the selected style guide. You should still double-check each of your sources against 

your style guide to make sure they're correct. If you need a quick reference for MLA, APA, or Chicago 

formatting. 

If you add more sources to your document, you can easily update your bibliography—just 

click it and select Update Citations and Bibliography. 

 

FIGURE 2. 15 LIST OF REFERENCES  

 

 

Updating the bibliography or works cited page 
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Now that you have added a citation, you can update your bibliography or works cited page in 

the same way that you updated the table of contents. To do this, scroll to your bibliography page and 

use your mouse to click near the “Bibliography” or “Works Cited” heading. When the “Update 

Citations and Bibliography” tab appears, click it. Notice that your bibliography page automatically 

added the citation you created earlier and in the correct style format that you chose when setting up the 

bibliography in the first place. 

 

 

Table of contents 

A table of contents helps readers navigate the basic structure of a document. To simplify your 

document creation process, Word automates the generation of a table of contents. This feature allows 

you to easily and efficiently create and update a table of contents. 

Before Word creates the table of contents, you must decide which material will be included 

and how it will appear. To indicate which elements should be included, you should designate each 

element using Heading styles. For example, a main section in your document may be labeled Heading 

1 and all subtopic headings below it might be labeled Heading 2. Once the table of contents is 

generated, these heading and style designations will be reflected as levels in the table.  

Adding section and subsection headings 

The first step to successfully creating a table of contents in Word is to separate your document into 

logical sections. Some of the sections may also be divided into relevant subsections. Practice with a 

sample Word document using the steps listed below. 

1. Open a document that contains multiple pages and paragraphs. 

2. Take time to add appropriate main section headings and several subheadings throughout the 

document. Do not format the font appearance of the headings at this time. In Figure 17, you 

will notice the headings added above each paragraph.  

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

47 

 
 

Applying heading styles (marking your document) 

The second step of building the table of contents involves marking your document so Word knows 

what wording to use to build the table of contents. Word thinks of your section headings in a 

hierarchical manner. Heading 1 is used for the highest level of heading (e.g., page titles or main section 

areas). Heading 2, 3, and so on, up to 9, would be used to identify subheadings under your main 

heading. Keeping this structure in mind, format the headings and subheadings in your document with 

the appropriate styles by following these steps: 

1. Click once anywhere within the first main heading that you want to assign to a style. 

2. On the Home tab, in the Styles group, choose Heading 1from the style gallery  

 

 
FIGURE 2. 16 HEADINGS 

3. Repeat for each of your main section headings. 

4. Then, format each of your section subheadings in the style of Heading 2 or Heading 3. 

5. Continue to apply the appropriate heading style to each of your document section headings and 

subheadings. Note the highest heading level you use; you will need to refer to it when inserting 

the table of contents in the next section. 
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Inserting the table of contents 

Once you have appropriately formatted your document with headings using the various Word 

heading styles, you can add the table of contents at the beginning of your document. The table of 

contents will be built based on the heading numbers (styles) you have used throughout the document. 

These heading numbers are also referred to as levels. To insert a table of contents in your document, 

follow these steps: 

1. Move to the page in your document where you want to add the table of contents. If necessary, 

insert a blank page. 

2. Type in a page heading near the top of the page (e.g., Table of Contents). 

3. Position the cursor below the page heading. 

4. On the References tab, in the Table of Contents group, click Table of Contents. 

5. Click Insert Table of Contents...at the bottom of the gallery. 

6. In the Table of Contents dialog box (see Figure 20), choose a format from the General area in 

the lower left corner. Options include: Classic, Modern, Simple, and more. The choice you 

make here determines the initial appearance of the table. 

7. In the Show levels spin box, choose the highest heading level (style) you want visible in the 

table. The number should correspond with the highest heading level used in the document.  

8. Under the Print Preview area, check the boxes to "Show page numbers" and/or "Right align 

page numbers". 

9. If necessary, choose a Tab leader from the drop down list. 

10. Click the OK button and the table of contents is added to the page. 
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FIGURE 2. 17 INSERT TABLE OF CONTENT 

Updating the table of contents 

If you change the page numbers or headings in a document containing a table of contents, you have 

the option of updating the table of contents to reflect those changes. Follow these steps to change the 

document and automatically update the table of contents: 

1. Make a change to one of the existing document section headings or subheadings. Or, 

insert/remove a section heading or subheading. 

2. On the References tab, in the Table of Contents group, click Update Table. 

3. Choose an option in the Update Table of Contents dialog box: 

a. If only page numbers have changed in the document, select Update page numbers only (see 

Figure 21). 

b. If headings have changed, select Update entire table. 

4. Click the OK button. 

5. View the page in the document that contains the table of contents. The changes in the heading 

and subheading text you made will be reflected in the updated table of contents. 
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2.3 Activities 

1. Your mission is to prepare a letter to someone you know discussing five things you like about 

Birzeit University and three things you dislike about BZU. The contents of your letter can be fiction 

or nonfiction.  

1.1. Your name and address should be centered and in italics at the top of the page with a Comic 

Sans font of 14 points.  

1.2. Insert your e-mail address (if any).  

1.3. Insert today's date, align it right.  

1.4. The name and address of your letter's recipient should be left aligned with a Comic Sans font 

of 9 points.  

1.5. At this point I would recommend saving your letter. Create a new folder on your student data 

disk called “BZU” and save this document as Word BZU in your Word exercises folder.  

1.6. The body of your letter should also use a Comic Sans font of 9 points.  

1.7. The first paragraph should contain the list of five things you like about BZU.  

1.8. The list should be numbered 1-5.  

1.9. Each item in the list must contain the phrase BZU 

1.10.The second paragraph should discuss three things you dislike about BZU.  

1.11.Each item should begin with a bullet.  

1.12.Each item must contain the phrase BZU.  

1.13.Close your letter with Sincerely, and your name left aligned at the bottom of the letter.  

1.14.Draw a smiley face at the bottom of the letter and colored it yellow. 

1.15.Put a border for the page and a beautiful background 

1.16.Check the spelling and grammar. 

1.17.Save your document again.  

2. Print your document. Write an article to direct students to some Web sites so that they too can read 

about places of interest. And be sure to contain the following: 

2.1. The names of websites must be in word gallery with shadow, and 3D shape style. 

2.2. Insert a picture that express about each website. 

2.3. Any comments about any website must insert in a footnote. (You should insert at least one 

comment). 

2.4. Insert a suitable symbol beside each website. 

2.5. Insert table with a suitable Dimensions which contain the name of each paragraph and number 

of words in it. 

2.6. Insert a reference.  

2.7. The space between lines must be 1.5 

2.8. Insert a page number (at a top in Latin format). 

2.9. Write the comments in Arabic and English language. 

2.10.Write the date of writing this article in the header of the page and the day in the footer of the 

page (right). 

 

 

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

51 

Experiment 3: Microsoft Office Excel  

 3.1 Objectives  

• Create and save document to a specified area.  

• Locate and open an existing document.  

• Identify different tools, menus, Bars of excel file.  

• Identifying parts of the worksheet (columns, rows, cells, labels, etc.)  

•  Identify the properties of cells, columns, rows.  

• Format (delete, insert, select, move, copy, paste) cells, columns, sheets and rows.  

• Use Auto Fill procedure.  

• Identify cell reference.  

• Create and write correct formulas.  

• Identifying excel Error types.  

• Identify functions of new icons like percentage, currency, and comma.  

• Draw and format charts.  

3.2 Context 

Microsoft Excel is an excellent spreadsheet program for manipulating data. Excel has the tools to 

manage data and perform complex mathematical functions, which may otherwise take hours to 

complete.  

However, the menu bar and 

shortcuts for Microsoft Word is 

nearly very similar to those for 

Microsoft Excel. Thus, this 

experiment  will  mainly 

concentrate on new things found 

in Excel.  

When you come familiar with 

Excel basics, you will find it 

easy to learn and can be fun to 

use.   

  

 

 

 

 

 

 Features of Excel  

An Excel file is called a workbook. A workbook can contain one or more worksheets. For 

organizational purposes, it is helpful to separate different sets of data by using different worksheets. 

A worksheet consists of 256 columns and 65,536 rows, for 16,777,216 cells per worksheet. The 

extension of excel is xlsx.       

 Figure 3. 18 Excel Interface 
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 Parts of the Worksheet  

1. Column – A vertical group of cells in a worksheet. A letter ranging from A to IV identifies each 

column.  

2. Column Headings – Sequential letters at the top of the worksheet.  

3. Row – A horizontal group of cells in a worksheet. The row number identifies each row.  

4. Row Headings – Sequential numbers along the left side of the worksheet.  

5. Cell – Intersection of a column and row. Referred to by the column letter and then the row number. 

Example: A2  

6. Label – Identifies information on the spreadsheet. For example, a column might be labeled 

expenses.  

7. Value – The raw data in a spreadsheet  

  

 Columns  

To change column width  

1. Place the mouse pointer on the column heading divider line that divides the column that you want 

to change from its neighbor to the right.  

 

 
 

2. When your mouse pointer changes to a two-way arrow, click, hold, and drag the column divider 

line to the right or left.  

3. To change the width of multiple columns, click, hold, and drag through the column headings that 

you want to change (select non-adjacent columns by pressing and Column Heading Divider Lines 

holding the CTRL as you click). Then click, hold, and drag any divider line.  

To insert a column  

1. In the column heading area, right click on the column heading to the right of where you want to 

insert the new column  

2. Choose Insert  

Deleting a Column  

1. To delete a column, in the column heading area, right click on the column heading that you want to 

delete.   

2. Choose  Delete  

  Hiding a Column  

1. To hide a column, in the column heading area, right click on the column heading that you want to 

hide.  

2. Choose Hide  
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1. To unhide a column, select the two columns where the hidden column is situated between them.   

2. Right click on the column heading then choose Unhide  

  

Applying and Modifying Cell Formats (Currency, Percent, and Decimals…..) 

1. Select the cell or range of cells.   

2. Right click on the selected cells and choose Format cells.  

3. Select the desired Category.  

4. Click OK.  

You may also choose from the Home menu the icon you want    

• Currency Style.   

• Percent Style.    

• Increase/Decrease Decimal.    

• Comma style to remove currency, percentage symbols.   

  

 

5.4.2 Rows  

 To change Row Height  

1. In the row heading area, place the mouse pointer on the divider line under the row you want to 

change.  

 
2. When your mouse pointer changes to a two – way arrow, click, hold, and  drag the row 

heading divider line up or down.  

3. To change the height of multiple rows, click hold, and drag through the row headings that you want 

to change (select non-adjacent rows by pressing and holding the CTRL key as you click). Then 

click, hold, and drag any divider line.  

  

Inserting a Row  

Right click on the row heading below where you want to insert a new row and choose Insert from the 

shortcut menu box.  

 Deleting a Row  

Right click the row heading of the row you want to delete and click Delete from the shortcut menu.  

 Hiding a Row  

1. To hide a row, in the row heading area, right click on the row heading that you want to hide.  
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 2. Choose Hide  

Un hiding a Row  

1. To unhide a row, select the two rows where the hidden row is situated between them.   

2.  Right click on the row heading then choose Unhide  

  

Sorting  

To Sort rows in ascending (A to Z) or Descending order based on the content of one column follow 

the steps shown in the figure  

 

   

1. Right click on any cell in the 

column you want to sort.  

2. Choose sort then (sort A to 

Z ) or ( sort Z to A)  

3. You can also use the sort 

icon in the Home menu   

 

 

                                                             Figure 3.2 sorting 

 

Cells:  

Inserting Cells  

1. Click where you want to insert the cell or select a range of cells that you 

want to insert.  

2. Right-click on the selected cell(s) and choose Insert. The Insert dialog box 

will appear.  

3. Make a choice for how you want the cells to be shifted and click “ok”.  

 

Deleting Cells  

1. To delete a cell, select and highlight the cell you wish to delete.  

2. Right click on it and choose Delete.  

3. The Delete dialog box will appear.  

4. Make a choice for how you want the cells to shift and click okay.  
  

Merge and Center Cells:  

 To merge cells as seen below, do the following:  
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Figure 3.3 Merge cells 

1. Select the cells you want to merge.  

2. Click the Merge and Center button in the Home menu.  

3.   
4. Type the title.  

  

Moving Cells through Cutting:  

     Cutting cell content means that the data will be moved to another cell.  

1. Select the cell or cells you want to cut.  

2. Right click on the selected cells then click cut.  

3. Select the location to move the data to then right click on that then choose Paste.  

4. The short cut key for cutting is Ctrl+X.  

  

Moving Cells Drag and Drop:  

  If you are moving the cell content only a short distance, the drag-and-drop method may be more 

efficient.  

1. Simply click and hold the highlighted border of the selected cell.  

2. Drag it to the destination cell with the mouse.  

3. Release the mouse button and the selected data moves.  

  

Moving Cells using Copy and Paste:  

When you want the same data to be present at several locations, it is best to copy this data rather than 

type it at each location. You can copy data within a worksheet, across worksheets, across 

workbooks, and even to and from other applications.  

1. Select the cells you wish to copy.  

2. Right click on the selected cells then choose Copy   

3. Select the location where you would like the copied cells to appear.  

4. Right click on that place then choose Paste.  

5. The shortcut keys copying and pasting are Ctrl+C to Copy and Ctrl+V to Paste.  

 

Worksheet:  

An Excel workbook may contain many worksheets. To navigate to a new worksheet, click on the 

desired sheet tab (bottom left corner of the screen).  

  

  

 

To insert a new single worksheet:  

1. Right click on any sheet then choose insert  
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2. From the window which will be shown choose worksheet   

3. Click OK   

  You can also insert a new sheet by pressing the icon:    
  

  

Rename a Worksheet:  

1. Double-click the sheet tab that you would like to rename.  

2. Type a new name over the current name and press Enter.  

  

Moving a Worksheet:  

1. Click and hold the mouse button on the sheet tab that you would like to move.  

2. Drag the sheet to its new location, a small black insertion arrow shows where the worksheet will be 

inserted.  

  

Delete a Worksheet:  

1. Right Click on the sheet you want to delete.  

2. From the menu choose delete.  

 

 Selecting  

Selecting with the SHIFT key:  

The shift key is used to select all the cells in a row column or range from one point to another.  

1. Select the starting cell.  

2. Hold the SHIFT key.  

3. Click the ending cell of the selection.  

  

 

  

Selecting with the CTRL key:  

The control key lets you select non-adjacent cells.   

1. Select a cell.  

2. Hold the CTRL key, select another cell.  

3. Continue holding CTRL and selecting cells until all the cells you want selected are.  

 

Pasting Linked Data  

When you paste data from one cell to another you can link the data so if is changed in the original cell 

it will change in any copied cell.  

1. Highlight the data you want to copy.  

2. Right click and choose Copy.  

3. Go to the cells you wish to copy to.  

4. Right click and choose from Paste options choose the link button.  

  

AutoFill:  

Fills are a good way to save time when entering data. AutoFill allows you to fill a row or a column of 

adjacent cells with a series based on the information in a single cell. You can do this with dates, 

time, months, years, numbers, and even formulas.  
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1. Select the cell with data that you would like to begin your series with.  

2. Place your mouse pointer in the lower right corner of the active cell.  

3. The mouse pointer will change to a fill pointer. Click, hold, and drag the fill 

pointer into a row or column of adjacent cells.  

 

Protection:  

Protect a Sheet:  

To protect a sheet so as nothing can be changed in the sheet content do the following  

1. On the Review menu, choose Protect  

2. Sheet.  

3. Enter a password.  

4. Check the boxes you want.  

5. Click OK.  

6. A confirm Password dialog box will appear.  

7. Enter the same password and click OK. 

 

 

 

 

Note: An Error massage will appear if you try to change or add anything to the protected sheet   

 
  

  

Chart Wizard   

In Excel, you can create charts from your worksheet data. A wide range of standard, business, and 

technical charts are available. It is 

important to accurately represent 

your data using the appropriate 

chart. There are three types of basic 

charts:  

1. Bar charts: illustrate individual 

values at a specific point at time.  

2. Line charts: illustrate changes in a 

large number of values over a long 

period of time.  

3. Pie charts: show the relationship of 

each part to the whole.   

 

To create a chart:  

1. Select a cell in the data to be plotted.  

2. From Insert Menu choose the desired chart   

Figure 3. 4 Protection 
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Figure 3.5 Create Chart  

  

Editing the chart   

Click once the chart so as to show the Design menu and Layout menu From the Design Menu:  

1. Select the color you want for the chart (the columns in this example)  

 
Figure 3.6 Editing the Chart 

 

Cell Reference  

A cell reference identifies a cell or a range of cells on a worksheet and tells Microsoft Excel where to 

look for the values that you want to use in a formula. With references, you can use data contained 

in different parts of a worksheet in one formula. You can also refer to cells on other sheets in the 

same workbook or to other workbooks.  

Excel uses cell references which refer to columns with letters (A through IV, for a total of 256 columns) 

and rows with numbers (1 through 65,536). To refer to a cell, enter the column letter followed by 

the row number.  

Examples of references  

 The cell in column A and row 10: A10  

 The range of cells in column A and rows 10 through 20: A10:A20  

 The range of cells in row 15 and columns B through E: B15:E15 

 All cells in row 5: 5:5  

 All cells in rows 5 through 10: 5:10 

 All cells in column H:  H:H  

 All cells in columns H through J: H:J  

 The range of cells in columns A through E and rows 10 through 20: A10:E20  

 

Formulas  

A formula is an equation that performs operations on worksheet data. Formulas can perform 

mathematical operations, such as addition (+), subtraction (-), multiplication (*), and division (/). 

Formulas can refer to other cells on the same worksheet, cells on other sheets in the same workbook, 

or cells on sheets in other workbooks.  
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The structure or order of the elements in a formula determines the final result of the calculation. 

Formulas in Microsoft Excel follow a specific order that includes an equal sign (=) followed by the 

elements to be calculated. Example: =A1+A2  

Excel performs the operations from left to right. You can control the order of calculation by using 

parentheses to group operations that must be performed first.   

Excel follows these rules:  

Expressions within parentheses are processed first. Multiplication and division are performed before 

addition and subtraction. Calculations are performed from left to right. This is called the order of 

operations. An easy way to remember is the mnemonic.  

Entering a Formula Manually  

1. Click the cell in which you want to enter a formula.  

2. Type “=”. The equal sign tells Excel that he succeeding characters constitute a formula.  

3. Enter the formula. Examples: a.  

a. =A1+A2  

b. =C7*F6  

c. =F13/5.5  

4. Press Enter.  

 

    Note: Your formula will appear in the Formula bar  

  

 
 

Functions  

A function is a predefined formula that operates on values and returns a value. All functions consist of 

a function name followed by a set of arguments enclosed in parentheses. To use a predefined 

function:  

1. Select the cell where you want the result to appear.  

2. Click the Insert Function button.   

3. Click to select the desired Function Category (Most Recently Used…..)  

4. Click to select the desired Function Name (Average, Sum, If, etc.).  

5. Click OK. The Functions Argument box will appear.  

6. In the formula palette, verify that the cells referenced are correct for the function. If the cells 

referenced are incorrect, specify the desired cells to be referenced.  

7. Click OK  

  

 Using Average  

1. Select a cell.   

2. Type = Average.   

3. Select a range (B10:B40).  

4. Type and press Enter.  

 

 Using MIN  
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1. Select a cell.  

2. Type = MIN.  

3. Select a range (D15:D40).  

4. Type and press Enter.  

 

 Using MAX  

The MAX function returns the largest number from a list of values.  

1. Select a cell.  

2. Type = MAX.  

3. Select a range (E5:E40).  

4. Type and press Enter.  

 

 Using COUNT  

   The Count function counts the number of cells that contain arguments.   

1. Select a cell.  

2. Type = COUNT.  

3. Select range to average (C5:C20).  

4. Type and press Enter.   

 

• Using AutoSum Menu  

AutoSum has pre-defined functions (MAX, MIN, SUM, AVERAGE, and COUNT) that automatically 

do calculations after selecting the wanted data.   

You can find the AutoSum icon in Home Menu or Formula Menu.  

 
Figure 3. 19 Auto Sum Menu 

Error types:  

    Most common Errors:  

• #VALUE! : You add a letter to number  
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• #NAME? :   You write a wrong function name.   

  

  

  

  

  

• #DIV/0! :  when a number is divided by zero  

  

  

 

 

 

• ####### : the width column is too narrow 
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3.3 Activities 

 

1. Insert the following data into an excel sheet. Note the following formatting: 

 Font size: 14  Font type: Ariel 

 
 

2. Set the width and height of the table to “AutoFit” 

3. Recolor the cells, using Cell Styles. 

4. Merge the first column as shown in the table 

5. Change the text direction for the first column and first row as shown in the table. 

6. Change the format of the numbers in the column “Price” to Accounting. 

 

7. In a separate sheet do the following using Auto Fill: 

a. Make a list the names of the days of the week 

b. Make a list the names of the months of the year 

c. Make a list of even numbers. 

 

8. How can we use excel to make simple calculations, like addition (+), subtraction (-), 

multiplication (*), and division (/)?  

 

9. How do we name  

a. Individual cells?  

b. Cells in a row?  

c. An entire row? 

d. Cells in a column?  

e. An entire column? 

f. A group of cells? 

 

 

 

 

 

 

 

 

 

 

 

10. Add a new column, call is “Total Price”, 

and calculate the values in it as follows: 

Total Price = Quantity * Price 

11. How can we use Auto Fill to make this 

task easier? 

12. Insert a row called “Max”, and calculate 

the maximum value in the “Quantity” and 

“Price” columns. 

13. Insert a row called “Min”, and calculate 

the minimum value in the “Quantity” and 

“Price” columns. 

14. Insert a row called “Sum”, and calculate 

the summation of values in the 

“Quantity” and “Price” columns. 

 

15. Hide the “Item” column, and unhide it 

again. 
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16. Sort the data ascending according to the 

“Item” name. 

17. Use conditional formatting to highlight 

the numbers in the column “Total Price” 

as follows: 

a. The numbers that are below 

average should be highlighted 

in Red. 

 

 

 

 

b. The numbers that are above 

average should be highlighted 

in Green. 

 

18. Draw a column chart that shows the total 

price of each item. 

19. Draw a pie chart that shows each item’s 

price. 

20. Draw a line chart that shows the quantity 

of each item. 
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Experiment 4: Numbering Systems 

4.1 Objectives 

 To be familiar with known numbering systems including decimal 

 To be familiar with converting integers between different numbering systems 

 To be familiar with converting fractions between different numbering systems 

 To perform Addition and subtraction of binary numbers using 2’s complement. 

 To gain the ability to represent different data types in memory.  

4.2 Context 

There are many ways to represent the same numeric value. Long ago, humans used sticks to count, and 

later learned how to draw pictures of sticks in the ground and eventually on paper. So, the number 5 was 

first represented as: | | | | | (for five sticks). 
 

Later on, the Romans began using different symbols for multiple numbers of sticks: | | | still meant three 

sticks, but a V now meant five sticks, and an X was used to represent ten of them! 

Using sticks to count was a great idea for its time. And using symbols instead of real sticks was much 

better. One of the best ways to represent a number today is by using the modern decimal system. Why? 

Because it includes the major breakthrough of using a symbol to represent the idea of counting nothing. 

About 1500 years ago in India, zero (0) was first used as a number! It was later used in the Middle East 

as the Arabic, sifr. And was finally introduced to the West as the Latin, zero. Soon you'll see just how 

valuable an idea this is for all modern number systems. 

 
 

Decimal System 

 

Most people today use decimal representation to count. In the decimal system there are 10 digits: 
 

0, 1, 2, 3, 4, 5, 6, 7, 8, 9 

 

These digits can represent any value, for example: 
 

754. 
 

The value is formed by the sum of each digit multiplied by the base (in this case it is 10 because there 

are 10 digits in decimal system) in power of digit position (counting from zero): 

 

 

 

Position of each digit is very important!   for   example   if   you   place   "7"   to   the   end: 
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it will be another value: 
 

Binary System 

 
Computers are not as smart as humans are (or not yet), it's easy to make an electronic machine with 

two states: on and off, or 1 and 0. 

 

Computers use binary system, binary system uses 2 digits: 
 

0, 1 And thus the base is 2. 

 
Each digit in a binary number is called a BIT, 4 bits form a NIBBLE, 8 bits form a BYTE, two bytes form a 

WORD, and two words form a DOUBLE WORD (rarely used): 

 

 

 

There is a convention to add "b" in the end of a binary number, this way we can determine that 101b is 

a binary number with decimal value of 5. 

 

The binary number 10100101b equals to decimal value of 165: 
 
 
 

 

Hexadecimal System 

 

Hexadecimal System uses 16 digits: 
 

0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, F 

 

And thus the base is 16. 
 

Hexadecimal numbers are compact and easy to read. Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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It is very easy to convert numbers from binary system to hexadecimal system and vice-versa, every 

nibble (4 bits) can be converted to a hexadecimal digit using this table: 
 
 

13 1101 D 

14 1110 E 

15 1111 F 

Decimal   Binary Hexadecimal 

(base 10) (base 2) (base 16) 

0 0000 0 

1 0001 1 

2 0010 2 

3 0011 3 

4 0100 4 

5 0101 5 

6 0110 6 

7 0111 7 

8 1000 8 

9 1001 9 

10 1010 A 

11 1011 B 

12 1100 C 
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There is a convention to add "h" in the end of a hexadecimal number, this way we can determine that 5Fh is a hexadecimal 

number with decimal value of 95. 

 

We also add "0" (zero) in the beginning of hexadecimal numbers that begin with a letter (A..F), for example 0E120h. 

 

The hexadecimal number 1234h is equal to decimal value of 4660: 
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4.3 Activities 

 

Activity 1: Convert the following 8-bit numbers from binary to decimal.  

a. 000101012  

b. 101101012  

c. 110100112  

d. 011010002  

 

Activity 2: Determine whether the following statements are true or false.     

e. 10012  <  510  

f. 01112  =  11110  

g. 00112  >  210  

h. 10012  >  11012  

i. 10112  =  1110  

j. 11112  =  1510  

k. 00002  <  010  

l. 11012  >  10102  

 

 

Activity 3: Convert the following numbers to their binary equivalents.    

a. 2710  

b. 3310  

c. 5410 

d. 20010  

e. 54910 

Activity 4: Convert the following numbers to their binary equivalents.    

a. 27.37510  

b. 33.7510  

c. 54.12510  

d. 47.87510  

e. 78.62510  

Activity 5: Use the 32-bit floating representation to represent the binary numbers you have got from the previous 

question.  
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Activity 6:Convert the following decimal numbers to binary. Work until you are sure your binary answer is 

repeating.   

a) 0.210  b) 0.310  c) 0.410  

Activity 7: Add the following 8-bit binary numbers.    

a. 010011102 + 001111002  

b. 100111012 + 100011112  

c. 110100112 + 010101102  

d. 100100112 + 101110012  

e. 111111102 + 101101012  

Activity 8: Convert the following decimal numbers to binary using 8-bit 2's complement representation.    

1. -1610   

2. 1310   

3. -310   

4. -1010   

5. 2610   

6. -3110  

Activity 9: Solve each of the following 8-bit subtraction problems using 2's complement representation.   

a. 011111112 - 7810  

b. 001100102 - 12310  

c. 010010012 - 11110  

d. 000001112 - 3510  

Activity 10: Convert the following numbers to decimal.  

a. 718  

b. 7116  

c. DE016  

d. 110118  

e. ABC16  

f. 100116  

g. 70.78  

h. A1.F16  

Activity 11: Using the odd parity bit to represent the following sentence in memory (Hexadecimal)? 

My Name Is -write your first name-  
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Experiment 5: Microsoft Office PowerPoint 

 
5.1 Objectives 

 What is a presentation, its types and what should contain. 

 To introduce the PowerPoint main functions. 

 To be able to create a PowerPoint presentation document, add text animation, Slide transition. 

 To add sounds, videos, pictures in addition to text in the presentation. 

 To control the slides during the presentation. 

 To use different views and printing options. 

 

5.2 Context 

PowerPoint is one of Microsoft Office applications; it is used to create the presentation slides with text, 

graphics and sounds. Slides are the individual parts of a presentation, they are similar to the individual pages 

in a print document, and they can contain text, graphics, and/or animation. 

PowerPoint has features enable the slides, text and the graphics to be animated. When you play a PowerPoint 

presentation slides and the other objects can move automatically or with your mouse click, these movements 

called special effects (Slide Transition and Animation Effects). 

 
 

What is a Presentation? 

A presentation is a means of communication, which can be adapted to various speaking situations, such as 

talking to a group, addressing a meeting or briefing a team. To be effective, step by step preparation and the 

method and means of presenting the information should be carefully considered. 

 
 

Types of presentations 

1. Quick 1-minute “what I do” talk. 

2. 25-minute conference paper presentation. 

3. Project presentation. 

4. Thesis defense. 

5. Job talk. 

 
 

What they have in common: 

 
1. Never enough time to talk about everything. 

2. All of them reflect on you & need practice/polish. 

3. Focus on a clear goal and message. 

Top 10 pointers for a good talk 
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1. Be neat. 

2. Avoid trying to cram too much into one slide, do not be a slave to your slides. 

3. Be brief, use keywords rather than long sentences. 

4. Avoid covering up slides. 

5. Use a large font. 

6. Use color to emphasize. 

7. Use illustrations to get across key concepts, may include limited animation. 

8. Make eye contact. 

9. Be ready to skip slides if time is short. 

10. Practice!! 
 

What should my presentation contain? 

1. Who am I? 

2. What is the problem? 

3. Why is it important? 

4. What have others done? 

5. What is my approach? 

6. Summary, future work, backup slides. 

 
 

Getting Started with Microsoft power point 2016 

Click on the start button, point to All programs then Microsoft office and click on Microsoft 

office power point 2016 .the window appears and your screen looks similar to the one shown 

below. 

 

 
 

 
Figure 5. 1PowerPoint 2016 Window 
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Creating a New Presentation 

Any presentation will consist of slides; these slides with their "Types" specify the way of data arrangements. 

The first time you start the PowerPoint a slide of type "Title Slide" is created, then you can create 

more slides by: 

 Go to Home in the ribbon, then to the Slides group, and then 

click on new slide .  

Normal slide: 

Usually the first slide in a presentation is a "Title Slide", this slides type looks like the 

following figure: 

 
 

 
Figure 5. 2Title slide 

 

  It is used to introduce the presentation, click in the space labeled "Click to add title" and type a title 

for the presentation, for example type your favorite book title, do the same thing for the space labeled "Click to add 

subtitle" and you can type the author name. 

Adding Bullets Slides 

You can use bulleted or numbered lists to help organize your text or show a sequential process 

in your PowerPoint presentation. 

1. Create a new slide (as described previously in this experiment). 

2. A new slide will appear and a second slide will appear on the left screen, it should 

look like the one below: 

 

 

 

 
Formatting Bullets: 

Figure 5. 3Adding Bullets 
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Go to the "Home" tab, then to the “Paragraph group” and click on "Bullets" , then 

choose "Bullets and Numbering" a dialog like the following figure enables you to choose 

your bullets and customizing it. 

 

Figure 5. 4 Formatting Bullets 

 

 
Changing Slide Layout: 

When you create a new slide, you can change slide layout by: 

 Go to Home in the ribbon, then to the Slides group , and then 

click on Layout , now you can select the layout you need and change the 

layout of selected slide. 

 

 
9.1.2. Adding a ClipArt and Picture Slide: 
Pictures not only add visual interest but also assist in getting your message across. Clipart is used to 

add pictures to your presentations. 

PowerPoint 2016 offers you a number of different ways to add clip Art and pictures to your 

presentation. 

 One of them is to select a slide layout that contains a placeholder for content  such as 
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clip art and pictures as shown below 

 
 

Figure 5. 5 Adding a ClipArt and Picture 

 

 Go to Insert tab on ribbon, then to Illustrations and Images group, then click picture if you 

need to download picture from file or click on clip art to select one of Microsoft pictures 
 

Figure 5. 6 Illustrations and Images 

 
 

Adding a WordArt Slide 

WordArt is used to create special effects on the text; you can create curves, angles, waves, 3-D 

effects and many more. 

 Create a new slide. 

 
 Change the slide layout; choose the “Blank” layout. You should now have a 

slide that is completely blank. 

 
 Go to Insert tab on the ribbon, then to Text group now select word Art 
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Figure 5. 7 Text group 

 

 
 Choose a text layout and then click OK. 

 From format tab, you can choose formatting options and type your text then 

click OK. The WordArt will appear in the center of your slide. 

 You can drag text to move it from one place to another, also you can rotate text, 

there are many things you can perform on your text as you needed. 

Changing the text after formatting it using the WordArt: 

Double click the text, and then you can write your new text. 

Moving through presentation slides 

Moving can be done by clicking its thumbnail on the left of the screen, also you can move between 

slides by using the [Page up] and [Page Down] Keyboard keys. 

Advanced Option: You can move a selected object by pressing the arrow keys on the keyboard. 

This can help with precise positioning since each time you press the key, the object will move only 

a small amount. Holding down the [Ctrl] key at the same time will move in even smaller amounts. 

Formatting Slides 

Using Slide Templates 

PowerPoint has a number of built-in design templates. These are intended to make it quick and 

easy to design a presentation that has a neat, consistent look on each slide. It can format all of the 

slides in even a very large presentation. 

To use a design template in your presentation, do the following: 

 
 Go to the Design tab, then Themes group, and then click the more button in the 
Theme group. A menu of themes appears. Click the theme you want. 
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Figure 5. 8 Slide Templates 

 

 

Note: Using a design template will replace most of the formatting that you may have already 

applied. You can always continue to modifying the formatting after applying a template but 

formatting changes before using the template will mostly be lost. 

Add Background 

You can add dramatic effect to your theme by applying a background 

 Go to Design tab, then to Customize group , and then 

click format background button ,if you need apply selected 

background to all slides just click on “Apply to All” button. 
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Figure 5. 9 Format background 

 

                                Special Effects on Slides: 

One of the main features of the PowerPoint is to create animated text such as sound and motion 

(Transition) for the text and the slides. 

Slide Transitions 

Transitions determine how your presentation moves from one slide to the next. For example, a 

slide can move up onto the screen and replace the previous slide. 

 Choosing the slides: 

Before you can apply a transition, you must select the slides to apply the transition to; this 

can be done using one of the following ways: 

-Selecting slides in a group - Click on the first slide. Hold down [Shift] and click on 

the third slide. Those slides and any in between will be selected. Click in the 

blank space between the slides to de-select them all 
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-Selecting separate slides – click on the second slide. Hold down [Ctrl] and click on 

the fourth slide. Each time you click on a slide while holding [Ctrl] you will select the 

slide if it’s not already selected, and deselect it if it is already selected. Deselect all 

slides. 

 

 

 
 Add Transition 

-Selecting all slides – Click on one slide then press [Ctrl][A].All slides will be selected. 

 
-Go to Transitions tab, and then to the “Transition to This Slide” group, 

then click the more button in the “Transition to this Slide” group. A 

menu of transitions appears. To apply selected transition to all slides click 

the Apply to All button . 

-To add a sound to a transition 
Go to Animations tab, then click the down arrow next to the Transition 

Sound field and then click the sound you want. 

-To set the speed of transition 

Go to Animations tab, then click the down arrow next to the Transition 

Speed field and then click the speed you want. 

 
 
 

 
Figure5.10 Transitions 
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You can choose the appearance way of the slide (Automatic after 
 
 
 
 
 

a specified period or after a mouse click). 

Animation Effects 

Not only can whole slides have transition effects, but the individual objects on a presentation can also 

have animation effects. Many of these effects allow you to have certain objects hidden until you require 

them to be displayed. This can be especially useful for drawing attention to items in a bulleted list one at 

a time. 

 Choose one of the presentation slides then choose the text/picture/chart etc., the 

object you want to give a motion (Transition).

 Go to Animations tab, then Advanced Animation group, then choose "Add 

Animation", to get the following figure

 
 
 

Figure 5.11 Animations 

 

Try to choose some of these effects; once you did all the objects, some numbers should appear to the left 

of each object on the slide. These indicate the order each object will appear in the presentation. 
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Note the "Add Animation", now it has a description for the animations you chose, it might look like the 

following figure: 
 

Figure 5.12 Animation pane 

 

This enables you to reorder the objects order of appearance by dragging and dropping any animation 

description, also you can choose when the animation can start and the speed of its motion. 

Note: you can apply more than one animation effects on one object, but too many animation effects 

can make a very long and very tedious presentation. Use them for adding emphasis. Do not use them 

just because you know how. 

 
Adding Sound to Slides 

The PowerPoint helps you to add sounds to the presentation, from the Insert tab, go to Media group, and 

then choose Audio to get the following figure. 

 

 
Figure 5.13 Media 

 
 Select Audio from My PC to Navigate to the folder or disk drive where the sound is 

stored and then click to select the sound you want to insert and click ok.
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Figure 5.14 insert media 

 
 
 

You will be asked whether you want the sound to play automatically or when you click on the icon if you 

click "Automatically" this will mean that the sound will play as soon as that slide appears in your 

presentation, the other option "When Clicked" means the sound will play when you click on the sound 

icon that appears  . 

 
A sound icon will appear on the slide. While the presentation is playing, you can click on this icon to play 

the sound whenever you choose. When you are designing your slide, you can drag this icon to change 

where it is positioned on your slide (same as the animation it has an order in the presentation). 
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Viewing Presentations 

Once the presentation is all ready, how can you show it? 

 Choose the first slide, or the slide you want to start with.

 Click the icon in the bottom left corner of the PowerPoint window

 or press the [F5] key. 

 You can end the presentation at any time, press [Esc]. You can then press [F5] again to return 

to the presentation. Your presentation will also end once you have passed the final slide.
 

 During the slide show click your left mouse button or press the spacebar to advance 

to the next slide.

 If you want to move to the previous slide again, you can right-click on the screen and 

choose Previous. An even easier way to go backwards and forwards through the slides 

is to press the [Page up] key (for next slide) and the [Page down] key (for previous 

slide).

 
 If you would like to quickly get to a particular slide number, you can simply press the 

number of the slide you want to go to and then press [Enter]. For example, pressing

[1] and [Enter] on your keyboard while in slideshow view will take you straight to 

the third slide. It doesn’t matter if you have already passed the slide. If you have a lot 

of slides in a presentation it still works. 

Changing the view 

You can change the way the PowerPoint displays the slides, go to "View" tab and choose: 

 Normal View to get same as the previous diagram.

 Slide Sorter View to see all your slides in a small with a more functional page.

 Slide Show to plays your presentation from the current selected slide.
 

Figure 5. 15 presentation views 
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Printing Slides 

If you are doing a presentation using PowerPoint, your listeners may appreciate having some notes to follow 

on with. It may even benefit you as a presenter to have a copy of your presentation printed out in front of 

you so you can remember what is next in the presentation. 

 While your presentation is open, Select  Print from the File menu or press 

[Ctrl][P]. 

 Options similar to the following will appear. 

Figure 5.16 print your presentation 

 

Under Print what, click the list and select all slides. 

 

 
Slide Master 

 
a. What is this? 

The slide that stores information about the design template applied, including font 

styles, placeholder sizes and positions, background design, and color schemes. 

b. Create your own slide master 

i. On the ribbon, select the View tab > in the Master Views group >Click Slide 

Master 
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Figure 5.17 master views 

 

 

ii. On the  left of your  screen you will now  see a  column with slide  master 

thumbnails 

1. The top slide thumbnail is your main slide master. 

2. The rest only apply to slides using the corresponding slide layout. 

Figure 5.18 slide master 

 
 
 

iii. Work with main slide master 

1. Select the slide thumbnail at the top of the column (there is a 1to the left 

of the thumbnail) 

2. Changing this slide will affect every other slide in your presentation. 

iv. Text format on master slide 

1. The master title style is the text formatting that is used for the title created 

on any slide 

2. The main text style changes the look and feel of text in the main area of 

the slide. 
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5.3 Activities 

Activity 1:  

You should make a presentation that takes all the explained pointers above in 

consideration. Chose any topic and make your presentation about this chosen topic. 

Activity 2:  

Answer the following questions 

a. How can we add new slide?  

b. What is the difference between clicking on the icon that is on the New Slide button 

and the text part  ?  

c. How can we Change the slide's layout. What are the different available? 

d. How do you apply the background to the slide you are at? How do you apply it 

to the rest of the slide show? 

e. What is the difference between Transition and Animation? 

f. From where can we start the slide show? 
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Experiment 6: Algorithm 1 

6.1 Objectives 

 To be familiar with pseudocode using different logic 

 To be familiar with sequential logic 

 To be familiar with selection logic using IF and CASE structures  

6.2 Context 

Algorithm definition 

An Algorithm is a sequence of computational steps that transform the input into the output. 

There are many ways in which an algorithm can be expressed. Describing an algorithm requires a 

notation for expressing a sequence of steps to be performed. The four common option are as follows: 

1- Pseudocode 

2- Flowchart 

3- Normal Language (English) 

4- A real programming Language 

In this context pseudocode will be considered and other options can be considered as different forms 

of pseudocode. For example, flowcharts can be considered as a graphical form of pseudocode.  

Pseudocode 

Pseudocode (derived from pseudo and code) is a description of a computer programming algorithm 

that uses the structural conventions of programming language, but omits detailed subroutines or 

language specific syntax. 

Pseudocode standard 

Pseudocode is a kind of structured English for describing algorithm. It allows the designer to focus 

on the logic of the algorithm without being distracted by details of language syntax. At the same time, 

the pseudocode needs to be complete. It describes the entire logic of the algorithm so that 

implementation becomes a rote mechanical task of translating line by line into source code. 

In general, the vocabulary used in the pseudocode should be the vocabulary of the problem domain, 

not of the implementation domain. The pseudocode is a narrative for someone who knows the 

requirements (problem domain) and is trying to learn how the solution is organized. E.g  

Extract the next word from the line (good) 

Set word to get the next token (poor) 

 

Append the file extension to the name (good) 

name = name+extension (poor) 

 

Let x equals the addition of a to b (good) 

x=a+b (poor) 

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

87 

Note that the logic must be decomposed to the level of a single loop or decision. Thus “search the list 

and find the customer with higher balance is too vague because it takes a loop and a nested decision 

to implement it. It’s okay to use “Find” or “Lookup” if there’s a predefined function for it such as 

String.indexOf(). 

 Different structures could be used such as SEQUENCE, IF-THEN-ELSE and CASE structures in this 

experiment. In Experiment number 8 both FOR and WHILE structures will be introduced. 

Each designer may have their own personal style of pseudocode. Pseudocode is not a rigorous notation 

since it is read by other people, not by the computer. There is no universal standard for the industry, 

but for instructional purposes it is helpful if we all follow a similar style. For example, the keywords 

below are often used to indicate common input, output and processing operations: 

Input:  READ, OBTAIN, GET 

Output: PRINT, DISPLAY, SHOW 

Compute: LET, CALCULATE, COMPUTE, DETERMINE. 

Initialize: SET, INIT 

Add one: INCREMENT 

Subtract one: DECREMENT 

Pseudocode is made up of the following logic structures that have been proved to be sufficient for 

writing any computer program. 

1. Sequential Logic: 

It is used to perform instructions in a sequence, i.e. one after another. Thus for sequence logic, 

pseudocode instructions are written in an order in which they are to be performed. The logic flow of 

pseudocode is from top to bottom. 

Example1:  

Write an Algorithm (Pseudocode) to find the sum of two numbers 

1. Ask the user to enter the first number. 

2.  Read the first number and save it as x 

3. Ask the user to enter the second number. 

4. Read the second number and save it as y 

5. Compute z as x added by y. 

6. print z. 

Example 2: 

Write an Algorithm (Pseudocode) to find the area of rectangle 

1. Ask the user to enter the height of rectangle 

2. Read the height and save it as h 

3. Ask the user to enter the width. 

4. Read the width and save it as w 

5. Compute area as h multiplied by  w. Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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6. print  area. 

2. Selection Logic: 

It is also known as decision logic. It is used for making decisions and for selecting the proper path out 

of two nor more alternative paths in program logic. selection logic is depicted as either an 

IF…THEN…ENDIF or an IF…THEN…ELSE…ENDIF structure. The general form is: 

IF condition THEN 

SEQUENCE 1 

ELSE 

SEQUENCE 2 

ENDIF 

The ELSE keyword and “SEQUENCE 2” are optional. If the conditions is true SEQUENCE 1 is 

performed, otherwise SEQUENCE 2 is performed. 

A CASE structure indicates a multi way branch based on conditions that are mutually exclusive. The 

general form is: 

CASE expression of 

Condition1: SEQUENCE 1 

Condition2:SEQUENCE 2 

… 

Condition n: SEQUENCE n 

DEFAULT: other SEQUENCE 

ENDCASE 

Example 1: 

Write an Algorithm (Pseudocode) to determine whether a student pass or fail a certain course at BZU. 

1. Ask user to enter the grade 

2. Read the grade and save it as g 

3. IF g is greater than sixty THEN 

 Print “Pass” 

    ELSE 

 Print “Fail” 

  ENDIF 

Example 2: 

Write an Algorithm (Pseudocode) to determine whether a given integer is odd or even. 

1. Ask user to enter the number 

2. Read the number and save it as n 

3. Let r equals the remainder of integer division for n by two. Uploaded By: Ayham NobaniSTUDENTS-HUB.com
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4. IF r is equal zero THEN   

Print “Even” 

    ELSE 

 Print “Odd” 

  ENDIF 

Example 3: 

Write an Algorithm (Pseudocode) to translate a given title into corresponding word  

e.g Mr to Mister, Ms to Mizz ..etc 

1. Ask the user to enter the title 

2. Read the title and save it as T 

3. CASE T of 

  Mr: print “Mister” 

Mrs: print “Missus” 

Miss: print “Miss” 

Ms: print “Mizzr” 

Dr: print “Doctor” 

ENDCASE 

Example 4: 

Write an Algorithm (Pseudocode) to translate a given grade  into corresponding points 

e.g A to 4, B to 3 ..etc 

1. Ask the user to enter the letter grade. 

2. Read the grade and save it as G 

3. CASE G of 

  A: let points equal 4 

B: let points equal 3 

C: let points equal 2 

D: let points equal 1 

F: let points equal 0 

ENDCASE 

4. print points 
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6.3 Activities 

Activity 1:  

Write an Algorithm (pseudocode) to find the following for a given 3 digits’ integer 

A) sum of the digits 

B) print a number that considered as the reverse value for e.g if the given integer is 

412. The reverse is 214 

C)sort the digits in ascending order and print them. for e.g if the given integer is 412. 

The output is 124 

Activity 2:  

Write a Write an Algorithm (pseudocode) to simulate a simple calculator for two 

numbers with +, -, *, / operations. 

Activity 3:  

Write an Algorithm (pseudocode) to find the larges element between 5 given integers 
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Experiment 7: Algorithm 2 

7.1 Objectives 

 To be familiar with iteration logic using WHILE and FOR structures  

 

7.2 Context 

Iteration logic: it is used to produce loop when one or more instructions may be executed several times 

depending on some of the conditions. Two famous structures will be explained in this experiment: 

1) While structure with the form below: 

WHILE condition 

SEQUENCE 

ENDWHILE 

2)For structure with the form below 

FOR iteration bounds 

SEQUENCE 

ENDFOR 

Example 1: 

Write an Algorithm (Pseudocode) to print all the integers between zero and one hundred inclusively 

1. For I equals zero to One hundred 

 1.1 Print I 

 1.2 Add one to I 

ENDFOR 

Example 2: 

Write an Algorithm (Pseudocode) to find the average of 10 grades 

1. Set sum equal zero  

2. For I equals one to ten 

  2.1 Ask the user to enter the grade 

  2.2 Read the grade and save it as g 

  2.3 Let sum equals the old sum added to g 

  2.4 Add one to I 

ENDFOR 

3. Let average equals sum divided by ten 

4. Print average 

Example 3: 
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Write an Algorithm (Pseudocode) to find the average of unknown number of grades. Your algorithm 

should stop when -1 grade is entered. 

1. Set counter equal zero 

2. Set sum equal zero 

3. Ask the user to enter the first grade 

4. Read the grade and save it as g 

5. While grade is not equal minus one 

  5.1 Let sum equal the old sum added to g 

  5.2 Add one to counter 

  5.3 Ask the user to enter the next grade 

5.4 Read the grade and save it as g 

ENDWHILE 

6. IF counter is not equal zero THEN 

  Let average equal sum divided by counter 

  Print average 

Else 

  Print “No grades ” 

ENDIF 

Example 4: 

Write an Algorithm (Pseudocode) to count the number of evens and the number of odds for unknown 

number of integers. Your algorithm should stop when zero number is entered. 

1. Set counter even equal zero 

2. Set counter odd equal zero 

3. Ask the user to enter the first number. 

4. Read the number and save it as x 

5. While x is not equal zero 

  5.1 Let R equal the remainder of integer division for x by two 

  5.2 IF R is equal zero THEN 

   Add one to counter even 

  ELSE 

   Add one to counter odd 

  ENDIF 

1. Ask the user to enter the next number 

2. Read the number and save it as x 
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ENDWHILE 

6. Print counter even 

7. Print counter odd  
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7.3 Activities 

Activity 1: Write an Algorithm (pseudocode) that asks the user to enter 3 different integers  

and sort them in ascending order. 

Activity 2: Write an Algorithm (pseudocode) to find the following for any given integer 

   A) Sum of the digits 

   B) Maximum digit value. 

   C)Minimum digit value. 

                 Activity 3: Write an Algorithm (pseudocode) to decide whether a given number is perfect  

    or not. A perfect number is that which equals the sum of all its divisors  

    excluding itself (e.g. 6 is a perfect since it is equal to 1+2+3 while 9 is not  

    perfect)  
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Experiment 8: Programming using C 

 

8.1  Objectives 

 To write a simple C program.  

 To perform Arithmetic calculation in C language. . 

 To be familiar with variables. Constant and  Escape characters. 

 To be familiar with input/output operations using standard input/output library. 

 

8.2  Context 

In any language there are certain building blocks: 
 

• Constants 
 

• Variables 
 

• Operators 
 

• Methods to get input from user (scanf(), getch() etc.) 
 

• Methods to display output (Format Specifiers, Escape Sequences etc.) etc. 
 

 
Format Specifiers 

Format Specifiers tell the printf statement where to put the text and how to display the text. 

 
The various format specifiers are: 

 

%d => integer 
 

%c => character 
 

%f => float 
 

… 
 

Variables and Constants 

If the value of an item is to be changed in the program then it is a variable. If it will not 
 

change then that item is a constant. The various variable types (also called data type) in C are: int, 

float, char, long ,double, … they are also of the type signed or unsigned. 

 

Escape Sequences 

Escape Sequence causes the program to escape from the normal interpretation of a string, so that the 

next character is recognized as having a special meaning. The back slash “\” character is called the 

Escape Character”. The escape sequence includes the following: 
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\n => new line 
 

\t => tab 
 

\b => back space 
 

\r => carriage return 
 

\” => double quotations 
 

\\ => back slash etc. 
 

 
Taking Input from the User 

 
The input from the user can be taken by the following techniques: scanf( ), getch( ), 

 
Operators 

 
There are various types of operators that may be placed in three categories: 

Basic: + ,-,*, /, % 

Assignment: =, += ,-= ,*=, /=, %= 

 

Relational: <, > ,<=, >=, == ,!= 

 

Logical: && , || , ! 
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8.3 Activities 

Activity 1: Write a C program that print your name, your id, your section number and your 

instructor on separate lines. 

Activity 2: Convert the following arithmetic expressions into a C programs 

A) r = b2- 4ac 

B) .   k = 4.2(x+y)5/z – 0.52x/(y+z)  

(x+y)2 

 

Activity 3: Explain the output of the following 

float a,b; 

a=5/9; 

b=5.0/9; 

printf(“%f,%f”,a,b); 

 

Activity 4: Write a C program which accepts an integer that contains 3 digits and prints the 

reverse value of the integer. 

Example  input: 324  

      Output:423 
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Experiment 9: Functions 

9.1  Objectives 

 To distinguish between slandered and user defined function.\ 

 To use standard function in C Library  

 To write a user defined function. 

 To be familiar with types of functions depending on the return type and arguments. 

 

9.2  Context 

Functions are used normally in those programs where some specific work is required to be done 

repeatedly and looping fails to do the same.  

Three things are necessary while using a function. 

i. Declaring a function or prototype:  

The general structure of a function declaration is as follows:  

return_type function_name(arguments); 

Before defining a function, it is required to declare the function i.e. to specify the function prototype. 

A function declaration is followed by a semicolon ‘;’. Unlike the function definition only data type 

need  to be mentioned for arguments in the function declaration.  

ii. Calling a function:  

The function call is made as follows:  

variable = function_name(arguments); 

ii. Defining a function:  

All the statements or the operations to be performed by a function are given in the function definition 

which is normally given at the end of the program outside the main.  

Function is defined as follows  

return_type function_name(arguments) 

{  

Statements;  

}  

 

There are certain functions that you have already used e.g:  

clrscr( ), printf( ), scanf( ) etc.  

There are four types of functions depending on the return type and arguments:  

• Functions that take nothing as arguments and return nothing.  

• Functions that take arguments but return nothing.  
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• Functions that do not take arguments but return something.  

• Functions that take arguments and return something.  

A function that returns nothing must have the return type “void”. If nothing is specified then the 

return type is considered as “int”.  
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Figure 9.1: the moon orbit around the earth 

9.3  Activities 

Actvity 1: A manufacturer wishes to determine the cost of producing an open-top cylindrical 

container. The surface area (المساحة الكلية) of the container is the sum of the area of the circular 

base plus the area of the outside (πr2+2πrh). 

Write a program to read the radius of the base r, the height of the container h, the cost per 

square centimeter of the material (cost) and the number of containers to be produced 

(Quantity) from the user. You should calculate the cost of each container and the total cost 

of producing all the containers and print the results on screen. 

Activity 2: The distance from the center of the earth to the center of the moon is 
343711 km as shown in the figure below. 
The moon’s orbit around the earth is completely circular. The moon takes one whole month 

to finish a complete rotation around the earth. 

Write a C program that finds and prints the distance and speed explained below using the 

following functions: 

Function called dist_thous_yrs that receives the distance from the center of the earth to the 

center of the moon and returns the distance ( in km ) the moon covers orbiting around the 

earth for a thousand consecutive years. 

Function called day_speed that receives the distance resulting from the first function ( 

dist_thous_yrs ) and returns the speed (in km/sec) needed to cover the same distance in a 

single day. 
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Experiment 10:  If and Switch statement 

10.1  Objectives 

 To Understand the usage of if statement. 

 To use the logical operations to combiner logical expressions  

 To Understand of nested if and the usage of if-else if statement 

 To be familiar with the usage of the switch statement 

10.2  Context 

Normally, your program flows along line by line in the order in which it appears in your source code. 

But, it is sometimes required to execute a particular portion of code only if certain condition is true; 

or false i.e. you have to make decision in your program. There are three major decision making 

structures. The ‘if’ statement, the if-else statement, and the switch statement. Another less commonly 

used structure is the conditional operator. 

 

The if statement 

 

The if statement enables you to test for a condition (such as whether two variables are equal) and branch 

to different parts of your code, depending on the result or the conditions with relational and logical 

operators are also included. 

 

The simplest form of an if statement is: 

if (expression) 

statement; 

 
The if-else statement 

 

Often your program will want to take one branch if your condition is true, another if it is false. If only 

one statement is to be followed by the if or else condition, then there is no need of parenthesis. The 

keyword else can be used to perform this functionality: 

 

if (expression) 
 

{ 
 

statement/s; 
 

} 
 

else 
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{ 
 

statement/s; 
 

} 

 

Nested if statements 

 An if statement can be inside another if statement to form a nested if statement. 

 

switch Statements 

A switch statement executes statements based on the value of a variable or an expression. 

Here is the full syntax for the switch statement: 

switch (switch-expression) { 

case value1: statement(s)1; 

break; 

case value2: statement(s)2; 

break; 

... 

case valueN: statement(s)N; 

break; 

default: statement(s)-for-default; 

} 
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10.3  Activities 

Activity 1: Write a C program to distinguish between  A) odd or even for integers 

B) negative or positive for doubles C) Consonant or vowel for characters 

 

Activity 2: Write a C program which takes three sides a, b and c of a triangle as input and calculates 

its area if these conditions are satisfied a+b>c, b+c>a, and a+c>b(Help a= √ s(s-a)(s-b)(s-c) , where 

s=(a+b+c)/2 ) 

 Activity 3: Write a C program to make a simple calculator which should be able to do +,-,*,/,% 

Operations. 

 

 Activity 4: Write a C program which takes 5 integers as input and prints the largest one. 
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Experiment 11:  Loop 1 

 

11.1  Objectives 

 To implement the iteration logic using for statement 

 To implement the iteration logic using while statement 

 To implement the iteration logic using do-while statement 

 
 

11.2  Context 

Types of Loops 

 

1) for Loop 

2) while Loop 

3) do-while 
 

 

 

The for Loop 

 

for (initialize(optional) ; condition(compulsory) ; increment(optional)) 
 

{ 
 

Body of the Loop; 
 

} 
 

This loop runs as long as the condition in the center is true. Note that there is no semicolon after the 

“for” statement. If there is only one statement in the “for” loop, then the braces may be removed. If we 

put a semicolon after the for loop instruction, then that loop will not work for any statements. 

 

 
The while Loop 

 

while ( condition is true ) 
 

{ 
 

Body of the Loop; 
 

} 
 

This loop runs as long as the condition in the parenthesis is true. Note that there is no semicolon after 

the “while” statement. If there is only one statement in the “while” loop then the braces may be 

removed. 
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The do-while Loop 

 

do 
 

{ 
 

Body of the Loop; 
 

} while ( condition is true); 
 

This loop runs as long as the condition in the parenthesis is true. Note that there is a semicolon after the 

“while” statement. The difference between the “while” and the “do-while” statements is that in the 

“while” loop the test condition is evaluated before the loop is executed, while in the “do” loop the test 

condition is evaluated after the loop is executed. This implies that statements in a “do” loop are executed 

at least once. However, the statements in the “while” loop are not executed if the condition is not 

satisfied. 
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11.3 Activities 

Activity 1: Write a C program to print the number of passes and the number of failures in a class of n 

students, also let the program print the failure percentage. 

Activity 2: Write a C program that will prompt for and receive prices of several items. After the 

last price is entered, the sentinel amount of –1 is entered. The algorithm should calculate the 

number of items purchased, total cost of the purchase before tax and with the tax of 7.5%, and 

display the results on the screen. 

Activity 3: Write a C program which will read pairs of integers in a Loop. Each time it reads a 

new pair it checks if the first integer divides the second integer i.e (second%first = 0)when a 

program read such a pair it will exit the loop. 

Activity 4: Write a C Program which takes an integer and check whether it is prime or not.  

Activity 5: Write a C program that prints the following pattern up to Z 

A  B C D 

E  F G H 

I  J K L 

M  N O P 

Q  R S T 

U  V W X 

Y  Z 
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Experiment 12:  Loop 2 

12.1  Objectives 

 To write programs using nested loop 

 To be familiar with break and continue  

 

 

12.2  Context 

The Nested for Loop 

 

for (initialize ; condition ; increment) 
 

{ 

Body of the loop; 
 

for (initialize ; condition ; increment) 
 

{ 
 

Body of the loop; 
 

} 
 

Body of the loop; 
 

} 
 

The inner loop runs as many times as there is the limit of the condition of the external loop. This loop 

runs as long as the condition in the parenthesis is true. We can nest many loops inside as needed. 

The nested while Loop 

 

while (condition is true) 
 

{ 
 

while (condition is true) 
 

{ 
 

Body of the loop; 
 

} 
 

Body of the loop; 
 

} 
 

The inner loop runs as many times as there is the limit of the condition of the external loop. This loop 

runs as long as the condition in the parenthesis is true. We can nest many loops inside as needed. 
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break 

 The usage of break is simply to exit a certain loop base on a certain condition 
 
Continue 

       The usage of continue is simply to skip all the statements after in the loop and begin a new iteration 
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12.3 Activities 

Activity 1: What is the output for the following segments 
A) int i; 
    For(I =0; i<=5;i++){ 
 If(i==3) break; 
 Printf(“%d\n”,i); 
 } 
B) int i; 
    For(I =0; i<=5;i++){ 
 If(i==3) continue; 
 Printf(“%d\n”,i); 
 } 
C)int x,y,a; 
   For(x =1, a=1;x<=5;x++) 
     For(y=1;y<=5;y++) 
 Printf(“%d\n”,a++); 
 
Activity 2:  Write a C program to print the following pattern up to ten lines 
    0 
              1 1 1 
            2 2 2 2 2 
          3 3 3 3 3 3 3 
 
Activity 3: Write a C program to print a series of the first 50 prime numbers. 
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Experiment 13: Internet 

13.1 Objectives 
• What we mean by Internet?  

• Define what Ritaj is? And what are the main functionality the student can do on Ritaj?  

• What is search engines?  

• Identify the main services Google provides.  

• Knowing some of the famous social networking websites.  

• Identify some online applications.  

• Know how to set a strong password.  

13.2 Context  
Now a day we almost cannot find a house without this technology that has the name “Internet” which 

made our whole world a small country. Some computer scientists define Internet as the network of 

networks, we can imagine connecting two personal computers which give a simple network that can 

be expand with other 28 computers to provide our lab network (the one you are taking this lab in) this 

lab also connected with all other labs in Birzeit University to provide us the university network, our 

university connected with one of the Internet Service Providers  

(ISP’s) in Palestine, which also connected with other networks in the whole world to provide us the 

internet.  

There are some core technologies that enable the Internet to work:  

• TCP/IP: Transmission Control Protocol / Internet Protocol  

• IP Addresses:  

o Computers are identified by their ‘IP addresses.  

o The format is nnn.nnn.nnn.nnn (Each of these numbers falls in the range 0 – 255 e.g. 

127.0.0.1).  

o Hardware devices known as ‘routers’ glue all the different networks together.  

• The Domain Name System (DNS): Most website hosts use domain names rather than actual IP 

addresses.  

In this experiment we will talk about some important websites, internet related applications and we 

will learn some techniques with using them.  

 

Google (www.google.ps)  

A web search engine is designed to search for information on the World Wide Web (WWW) and FTP 

servers. The search results are generally presented in a list of results and are often called hits. The 

information may consist of web pages, images, information and other types of files.  

Typically, a search engine software works by sending out spiders to fetch as many documents as 

possible. Another program, called an indexer, reads these documents and creates an index based on 

the words contained in each document. Each search engine uses a proprietary algorithm to create 

its indices such that, ideally, only meaningful results are returned for each query the searcher types 

into a search engine.  

Search is always case insensitive. A search for [university] is the same as a search for [University] 

and general the punctuation is ignored, including @#$%^&*()=+[]\ and other special characters.  

 

Uploaded By: Ayham NobaniSTUDENTS-HUB.com



 

109 

There are many examples on search engines, the most popular one is Google and there are Bing, 

Yahoo, Ask.com, Aol.com, etc. in the rest of this activity we will focus on Google search engine:  

1. Each blue underlined line is a search result (see Figure 16) that the Google search engine found 

for your search terms. The first item is the most relevant match we found, the second is the 

next most relevant, and so on down the list. If you click the title of any result, you will be taken 

to that webpage.  

2. Figure 13.1 shows the main page of Google.ps:  

 

Figure 13. 1 GOOGLE MAIN PAGE 
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3. Figure 13.2 shows the results for the query introduction to computer, comp121, Birzeit university: 

 

Figure 13. 2 SEARCH RESULTS 

  

4. The following are some search helping phrases:  

 Phrase search (""): By putting double quotes around a set of words, you are telling Google 

to consider the exact words in that exact order without any change. "tallest building". 

 

 Search within a specific website (site:): Google allows you to specify that your search 

results must come from a given website. Birzeit.edu: Ahmed 

 

 Terms you want to exclude (-): Attaching a minus sign immediately before a word 

indicates that you do not want pages that contain this word to appear in your 

results.  jaguar speed -car 

   

 The OR operator: Google's default behavior is to consider all the words in a search. If you 

want to specifically allow either one of several words, you can use the OR operator (note 

that you have to type 'OR' in ALL CAPS or you can use the symbol “|”). marathon OR 
race. 

 

 (Remember, don't add a space when you using site: -)  

 

 

  

Google provides many other applications beside the search engine:  
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I. Google Gmail: A google mail or in other word the google account. Which we encourage all 

internet users to have one. And you can simply build one by visiting the following link: 

https://accounts.google.com/SignUp. Figure 13.3  shows the signup page:  

 

Figure 13. 3 GOOGL SIGNUP PAGE 

II. Google translate: Which is an online dictionary from any language to other language in the 

world!  

III. Google+: A social network website that you can add people on it and work like other social 

network websites (e.g. Facebook).  

IV. Google calendar: An online-shared calendar that can manage time between individuals and 

groups.  

V. Google Scholar: Provides a simple way to broadly search for scholarly literature. From one 

place, you can search across many disciplines and sources: articles, theses, books, abstracts 

and court opinions, from academic publishers, professional societies, online repositories, 

universities and other web sites.  

VI. Google Drive is a free service from Google that allows you to store files online and access 

them anywhere using the cloud. Google Drive also gives you access to free web-based 

applications for creating documents, spreadsheets, slides and more.  
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 Social networking  

A social networking service (also social networking site or SNS) is a platform to build social networks 

or social relations among people who share similar interests, activities, backgrounds or real-life 

connections. A social network service consists of a representation of each user (often a profile), his 

or her social links, and a variety of additional services such as career services.  

 

Some famous social networks:  

1. Facebook: General social networking that can share 

photos, videos, blogs and applications.  

2. Twitter: General social networking that is 

Microblogging, RSS and updates.  

3. LinkedIn: Business and professional networking 

(online CV). We highly recommending each student to 

have an account in this website. The following link is a 

tutorial on how to create an account on LinkedIn and 

how to make improve it:  

Title: LinkedIn Tutorial Series 2014. Channel: Anson 

Alexander. https://goo.gl/28zEXC 

 

4. Instagram: A photo and video sharing site.  

5. Ask.fm: Users create profiles and can send each other anonymous and non-anonymous questions.  

 Useful online applications and websites  

It is not a necessary anymore to install many applications on your 

personal computer. Now you can just search online for what you want 

to do, and there are many websites specialized on do your work for you. 

We mention some useful online applications (Please use google to 

search for them):  

  

1. Dropbox (www.dropbox.com): A storage space on the cloud 

starting with 2 GB, you can simply registered in this website by entering the website and enter 

your email address and setting a password. The application let you drag and drop or copy and paste 

your files to a virtual folder, which will synchronize your files in all places you open your account.  

2. Currency converter: Which provides you with the ability to select two currencies and convert from 

one to another. Just search for “Currency converter” on google.  

3. Online calculator: Just type your equation as query on google and it will provides you with 

scientific calculator with the result of your equation. For e.g. (25*2)+(8/2).  

4. Photo editing: If you search via google for photo editor, you will find a variety of web applications 

provide you with this service.  

5. YouTube to MP3: A website that download a given YouTube video link as a sound file (MP3 file).  

6. YouTube to MP4: A website that download a given YouTube video link as a video file (MP4 file).  

7. JPG to PDF: A website that takes multi-images and sort them in one pdf file.  
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8. Shrink PDF size: A website that takes a pdf file and compress its size as much as possible without 

effecting its quality.  

9. PDF to word: Converting a PDF file to doc/docx file.  

Password  

A password is a secret word or phrase that must be used to gain 

admission to a place. Do not ever give your password to anyone, do 

not put the same password for more than one account and do not write 

it on a paper and put it under the keyboard or the screen. Be fully aware 

that there is no site asks its users for their passwords under any 

circumstances.  In this section, we will provide some tips in order to 

create a strong and remembered password:  

1. Think of a sentence that have more or equal to 8 words. It can 

be a verse, piece of a song, a saying that touched you or 

anything you like, as an example I will use that sentence maybe each of our English teachers 

use: One apple a day keeps the doctor away.  

2. Now take the first letter of each word so the password would be “Oaadktda”.  

3. Let us try to convert the letters that looks like numbers to numbers (e.g. O looks like zero “0”) 

the new password: “0aadk1da”.  

4. Convert letters to special characters (e.g. the “a” letter looks like “@”) so the password: 

“0@@dk1d@”.  

5. We can make it even harder by having a mix of capital letters and small letters.  

 

The final password: “0@@dK1d@”. This password will never be guessing by the cracking tools and 

it also easy to regenerate by you.  
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13.3 Activities 
1. Create a strong password for each account you have.  

2. Create a google account and sign-in to google chrome browser.  

3. Could you differentiate between social networking and search engines?  

4. Identify the valid IP addresses in the following:  

a. 8.8.8.8  

b. 192.168.0.1.1  

c. 172.15.256.255  

d. 255.255.255.251  
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